summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/spaz/spaz-1.605.ebuild')
-rw-r--r--games-strategy/spaz/spaz-1.605.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-strategy/spaz/spaz-1.605.ebuild b/games-strategy/spaz/spaz-1.605.ebuild
new file mode 100644
index 000000000000..85950e1abfe4
--- /dev/null
+++ b/games-strategy/spaz/spaz-1.605.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit unpacker games
+
+DESCRIPTION="Space Pirates and Zombies"
+HOMEPAGE="http://spacepiratesandzombies.com"
+SRC_URI="${PN}-linux-humblebundle-09182012-bin"
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa pulseaudio"
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=media-libs/openal-1.15.1[alsa?,pulseaudio?,abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]"
+
+S="${WORKDIR}"/data
+
+QA_PREBUILT="opt/spaz/SPAZ"
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doexe SPAZ
+ doins -r common game mods
+ doins audio.so
+ newicon SPAZ.png spaz.png
+ dodoc README-linux.txt
+
+ games_make_wrapper ${PN} ./SPAZ "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Space Pirates and Zombies" ${PN}
+
+ prepgamesdirs
+}