summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/spaz')
-rw-r--r--games-strategy/spaz/Manifest1
-rw-r--r--games-strategy/spaz/metadata.xml8
-rw-r--r--games-strategy/spaz/spaz-1.605.ebuild45
3 files changed, 54 insertions, 0 deletions
diff --git a/games-strategy/spaz/Manifest b/games-strategy/spaz/Manifest
new file mode 100644
index 000000000000..2aaa60cb6738
--- /dev/null
+++ b/games-strategy/spaz/Manifest
@@ -0,0 +1 @@
+DIST spaz-linux-humblebundle-09182012-bin 157466422 SHA256 b143b8e0b09baec1f5c9f02daada9f1125bbd0109f0878e3b00b14657a4fb7cd SHA512 ba62be6a247dfb1ee04db8784b3e173140e7491f2bd68a528ad9c81cab4bc8f807bfeb4593fa37c76e43401420a6f788075cd2541fd16ed7443fe4301a76d50c WHIRLPOOL 508ec9ccfd2f75f52823628659d53568bc8e50da73866bad645a4910c4aee782b2d48488ec43b0a34bd7f7c829a18b2162052ae1293af661e09d50b193659665
diff --git a/games-strategy/spaz/metadata.xml b/games-strategy/spaz/metadata.xml
new file mode 100644
index 000000000000..b6b8956cde34
--- /dev/null
+++ b/games-strategy/spaz/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-strategy/spaz/spaz-1.605.ebuild b/games-strategy/spaz/spaz-1.605.ebuild
new file mode 100644
index 000000000000..85950e1abfe4
--- /dev/null
+++ b/games-strategy/spaz/spaz-1.605.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit unpacker games
+
+DESCRIPTION="Space Pirates and Zombies"
+HOMEPAGE="http://spacepiratesandzombies.com"
+SRC_URI="${PN}-linux-humblebundle-09182012-bin"
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa pulseaudio"
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=media-libs/openal-1.15.1[alsa?,pulseaudio?,abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]"
+
+S="${WORKDIR}"/data
+
+QA_PREBUILT="opt/spaz/SPAZ"
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doexe SPAZ
+ doins -r common game mods
+ doins audio.so
+ newicon SPAZ.png spaz.png
+ dodoc README-linux.txt
+
+ games_make_wrapper ${PN} ./SPAZ "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Space Pirates and Zombies" ${PN}
+
+ prepgamesdirs
+}