summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-06-23 19:36:09 +0100
committerJustin Lecher <jlec@gentoo.org>2018-06-23 19:36:56 +0100
commit3abbba9a1777bc050e67c510c1327f8a378c6e6e (patch)
tree7dd4d7653198632432060e16473576feb92c58ef /sys-cluster/ucx
parentsys-cluster/ucx: Fix numa support (diff)
downloadgentoo-3abbba9a1777bc050e67c510c1327f8a378c6e6e.tar.gz
gentoo-3abbba9a1777bc050e67c510c1327f8a378c6e6e.tar.bz2
gentoo-3abbba9a1777bc050e67c510c1327f8a378c6e6e.zip
sys-cluster/ucx: Version Bump
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-cluster/ucx')
-rw-r--r--sys-cluster/ucx/Manifest1
-rw-r--r--sys-cluster/ucx/ucx-1.3.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-cluster/ucx/Manifest b/sys-cluster/ucx/Manifest
index e0076771f8a2..6382831bd8a8 100644
--- a/sys-cluster/ucx/Manifest
+++ b/sys-cluster/ucx/Manifest
@@ -1 +1,2 @@
DIST ucx-1.2.2.tar.gz 1513611 BLAKE2B 488b9b3cecc2c617b1209036e1342e4378459db6a5e93eab1d88dfe80cb0d9c8013c767413206f0fbd0105557ed89994ab510421068d709101336a7b3d2eac5e SHA512 515c382826310b9aa7179ab19ceb76a881a41e6786514219b7f703c6144fa57ca141bceb3b80523ae1b4e2a4b13e9abcb9df063612b376d894c5cd81cdc00571
+DIST ucx-1.3.0.tar.gz 1707317 BLAKE2B 740ab240663a26fde8abe631416dae6233febf3c587ba6bb7b27a9cb0aa041540ce71e106bb3c5618a719de66d479055961908b67125df61a4c7696999c0affb SHA512 0a2e32985e0225fc4ad15dbb1c422dba1d5552638e7329d67572924502e61e1a481ce30cde5ccc83c663fb4ec643df83efc08aed164dfbce6cf38d66a16b3e42
diff --git a/sys-cluster/ucx/ucx-1.3.0.ebuild b/sys-cluster/ucx/ucx-1.3.0.ebuild
new file mode 100644
index 000000000000..eb6c279f6453
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="http://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ numa? ( sys-process/numactl )
+"
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}