summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-06-23 18:48:49 +0100
committerJustin Lecher <jlec@gentoo.org>2018-06-23 19:36:56 +0100
commitb55ebbeeeff8e43fe6be587c990d3c662c603128 (patch)
treec737cae82bd4314a87862f72596f4f40076b995d /sys-cluster/ucx
parentlxde-base/lxtask: amd64 stable wrt bug #654908 (diff)
downloadgentoo-b55ebbeeeff8e43fe6be587c990d3c662c603128.tar.gz
gentoo-b55ebbeeeff8e43fe6be587c990d3c662c603128.tar.bz2
gentoo-b55ebbeeeff8e43fe6be587c990d3c662c603128.zip
sys-cluster/ucx: Fix numa support
Closes: https://bugs.gentoo.org/654432 Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-cluster/ucx')
-rw-r--r--sys-cluster/ucx/metadata.xml3
-rw-r--r--sys-cluster/ucx/ucx-1.2.2-r1.ebuild (renamed from sys-cluster/ucx/ucx-1.2.2.ebuild)12
2 files changed, 12 insertions, 3 deletions
diff --git a/sys-cluster/ucx/metadata.xml b/sys-cluster/ucx/metadata.xml
index d11a30befa7f..6af00b86c7fa 100644
--- a/sys-cluster/ucx/metadata.xml
+++ b/sys-cluster/ucx/metadata.xml
@@ -9,4 +9,7 @@
<email>cluster@gentoo.org</email>
<name>Gentoo Cluster Project</name>
</maintainer>
+ <use>
+ <flag name="numa">Add support for numa memory allocation</flag>
+ </use>
</pkgmetadata>
diff --git a/sys-cluster/ucx/ucx-1.2.2.ebuild b/sys-cluster/ucx/ucx-1.2.2-r1.ebuild
index 0b581f7bf566..c3bf36aa7359 100644
--- a/sys-cluster/ucx/ucx-1.2.2.ebuild
+++ b/sys-cluster/ucx/ucx-1.2.2-r1.ebuild
@@ -12,12 +12,16 @@ SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="+numa +openmp"
+
+RDEPEND="
+ numa? ( sys-process/numactl )
+"
src_prepare() {
default
sed \
- -e '/^BASE_CFLAGS/s:=.*:=:g' \
+ -e '/BASE_CFLAGS=/s:=".*":=:g' \
-i config/m4/compiler.m4 || die
eautoreconf
}
@@ -25,5 +29,7 @@ src_prepare() {
src_configure() {
BASE_CFLAGS="" \
econf \
- --disable-compiler-opt
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
}