summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-10-04 13:45:49 +0100
committerMarek Szuba <marecki@gentoo.org>2022-10-04 13:50:23 +0100
commitdf42fda1b1c333d9e02a965d71fc2bbd2b808951 (patch)
treea0e7ad3c704a281d6b157c06a6b689cba28637e7 /games-engines
parentnet-p2p/syncthing: add 1.22.0 (diff)
downloadgentoo-df42fda1b1c333d9e02a965d71fc2bbd2b808951.tar.gz
gentoo-df42fda1b1c333d9e02a965d71fc2bbd2b808951.tar.bz2
gentoo-df42fda1b1c333d9e02a965d71fc2bbd2b808951.zip
games-engines/love: allow implicit function declarations in legacy slots
For the record, :0.7 and :0.8 are both ancient versions of LOVE which we only keep in the tree because of reverse dependencies - of which there are very few and which themselves are rather old. Closes: https://bugs.gentoo.org/874651 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/love/love-0.7.2-r100.ebuild9
-rw-r--r--games-engines/love/love-0.8.0-r100.ebuild9
2 files changed, 14 insertions, 4 deletions
diff --git a/games-engines/love/love-0.7.2-r100.ebuild b/games-engines/love/love-0.7.2-r100.ebuild
index b28e616cd1d7..8189b417ccce 100644
--- a/games-engines/love/love-0.7.2-r100.ebuild
+++ b/games-engines/love/love-0.7.2-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
LUA_COMPAT=( lua5-1 )
LUA_REQ_USE="deprecated"
-inherit lua-single
+inherit flag-o-matic lua-single
DESCRIPTION="A framework for 2D games in Lua"
HOMEPAGE="https://love2d.org/"
@@ -41,6 +41,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.8.0-freetype2.patch
)
+src_prepare() {
+ default
+ append-cflags -Wno-error=implicit-function-declaration
+}
+
src_install() {
DOCS="readme.txt changes.txt" \
default
diff --git a/games-engines/love/love-0.8.0-r100.ebuild b/games-engines/love/love-0.8.0-r100.ebuild
index 5ac4d20e65a0..c2d4a9c8c103 100644
--- a/games-engines/love/love-0.8.0-r100.ebuild
+++ b/games-engines/love/love-0.8.0-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
LUA_COMPAT=( lua5-1 )
LUA_REQ_USE="deprecated"
-inherit lua-single
+inherit flag-o-matic lua-single
DESCRIPTION="A framework for 2D games in Lua"
HOMEPAGE="https://love2d.org/"
@@ -39,6 +39,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.8.0-opengl_glext_prototypes.patch
)
+src_prepare() {
+ default
+ append-cflags -Wno-error=implicit-function-declaration
+}
+
src_install() {
DOCS="readme.md changes.txt" \
default