summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/love/love-0.8.0-r100.ebuild')
-rw-r--r--games-engines/love/love-0.8.0-r100.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/games-engines/love/love-0.8.0-r100.ebuild b/games-engines/love/love-0.8.0-r100.ebuild
index 5ac4d20e65a0..c2d4a9c8c103 100644
--- a/games-engines/love/love-0.8.0-r100.ebuild
+++ b/games-engines/love/love-0.8.0-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
LUA_COMPAT=( lua5-1 )
LUA_REQ_USE="deprecated"
-inherit lua-single
+inherit flag-o-matic lua-single
DESCRIPTION="A framework for 2D games in Lua"
HOMEPAGE="https://love2d.org/"
@@ -39,6 +39,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.8.0-opengl_glext_prototypes.patch
)
+src_prepare() {
+ default
+ append-cflags -Wno-error=implicit-function-declaration
+}
+
src_install() {
DOCS="readme.md changes.txt" \
default