summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 12:07:26 +0000
committerSam James <sam@gentoo.org>2021-04-04 12:38:41 +0000
commit38041cc3933654ef05fd94f5a1e3927344fdd2f2 (patch)
tree09380cb20f9d2982bd25aeda4dcb81e1ca593244 /games-arcade
parentgames-board/ascal: port to EAPI 7, eutils-- (diff)
downloadgentoo-38041cc3933654ef05fd94f5a1e3927344fdd2f2.tar.gz
gentoo-38041cc3933654ef05fd94f5a1e3927344fdd2f2.tar.bz2
gentoo-38041cc3933654ef05fd94f5a1e3927344fdd2f2.zip
games-arcade/gav: respect LD
Much easier to just assume we're dealing with the compiler interface. Closes: https://bugs.gentoo.org/779976 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gav/gav-0.9.0-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/games-arcade/gav/gav-0.9.0-r1.ebuild b/games-arcade/gav/gav-0.9.0-r1.ebuild
index 72320ba4673b..babd49793332 100644
--- a/games-arcade/gav/gav-0.9.0-r1.ebuild
+++ b/games-arcade/gav/gav-0.9.0-r1.ebuild
@@ -44,12 +44,19 @@ src_prepare() {
# Now, move the additional themes in the proper directory
mv ../{fabeach,florindo,inverted,naive,unnamed,yisus,yisus2} themes || die
- # no reason to have executable bit set on themes
+ # No reason to have executable bit set on themes
find themes -type f -exec chmod a-x '{}' \; || die
+
+ # Respect LD, bug #779976
+ sed -i -e 's/LD = ld/LD ?= ld/' CommonHeader || die
+ sed -i -e 's/$(LD)/& $(LDFLAGS)/' */Makefile || die
}
src_configure() {
tc-export CXX
+
+ # Nobody _really_ sets LD. Tell the compiler what to do instead.
+ export LD="${CXX}"
}
src_compile() {