summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/gav/gav-0.9.0-r1.ebuild')
-rw-r--r--games-arcade/gav/gav-0.9.0-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/games-arcade/gav/gav-0.9.0-r1.ebuild b/games-arcade/gav/gav-0.9.0-r1.ebuild
index 72320ba4673b..babd49793332 100644
--- a/games-arcade/gav/gav-0.9.0-r1.ebuild
+++ b/games-arcade/gav/gav-0.9.0-r1.ebuild
@@ -44,12 +44,19 @@ src_prepare() {
# Now, move the additional themes in the proper directory
mv ../{fabeach,florindo,inverted,naive,unnamed,yisus,yisus2} themes || die
- # no reason to have executable bit set on themes
+ # No reason to have executable bit set on themes
find themes -type f -exec chmod a-x '{}' \; || die
+
+ # Respect LD, bug #779976
+ sed -i -e 's/LD = ld/LD ?= ld/' CommonHeader || die
+ sed -i -e 's/$(LD)/& $(LDFLAGS)/' */Makefile || die
}
src_configure() {
tc-export CXX
+
+ # Nobody _really_ sets LD. Tell the compiler what to do instead.
+ export LD="${CXX}"
}
src_compile() {