summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-17 07:33:29 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-17 07:33:29 +0200
commit920d02549caae06b1f4ae434a569f4bcdb860cf1 (patch)
tree2ad83d47af1c8ef68fd4ce3d30404657e845c790 /dev-python
parentdev-python/cfn-lint: Bump to 1.14.0 (diff)
downloadgentoo-920d02549caae06b1f4ae434a569f4bcdb860cf1.tar.gz
gentoo-920d02549caae06b1f4ae434a569f4bcdb860cf1.tar.bz2
gentoo-920d02549caae06b1f4ae434a569f4bcdb860cf1.zip
dev-python/sybil: Bump to 7.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-7.1.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index eceb5d95b93f..fb9eb29b6f77 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,2 +1,3 @@
DIST sybil-6.1.1.gh.tar.gz 71447 BLAKE2B 44ced68adfae094454c9dc4ae55b7327fc9d149728ec9f2faafc42057bc9e99572289100e310f16afdde7741841964a365c008fc9a16092d270ce88dfb0d89be SHA512 f14bb09b8886bd17ccd3a56d3dfc8e2ff510ad04f7b9c8deadff826571e36547934af6855e0a6cbed43e0c0767a0f0af8f80afcecf4a8db74b041fae9d84bd5a
DIST sybil-7.0.0.gh.tar.gz 74678 BLAKE2B 17ff70054211437c1b1d2053c6f3cea78ba6e401310853ce1b8397caf992267338a7f868b33174d5bbba1c54c1709bade7f4474a0bcb2e8a59e6e9a93e308574 SHA512 ebc0300d0d36abf6307f9104887eb5f9daa78fa9a86bb985b3fbeb05ffbf1ed8a682c681a207dcd1ee0cb37b8448567a50c19ca3657f391a58655253798665d4
+DIST sybil-7.1.1.gh.tar.gz 75224 BLAKE2B df6946089aacdcd65ba76466e8bdc22481df9b9a3c2653d61ea5d29d1c323d33eecaf38dc718613d3503b38b2953b0deac7c8408b6e9b3fb37d519468361e7f1 SHA512 9c4ee6a166562a63281e151e6fcff4a274ac77d94180f35492f806d05da72daed4b9ae48b4095a90f6679bac226469e5d2ef5f48767a40f513efd295c9597b2c
diff --git a/dev-python/sybil/sybil-7.1.1.ebuild b/dev-python/sybil/sybil-7.1.1.ebuild
new file mode 100644
index 000000000000..6244e3506d0c
--- /dev/null
+++ b/dev-python/sybil/sybil-7.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}