summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-17 07:31:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-17 07:31:58 +0200
commiteaecb21abd5d1a1ee389a147d2f44e5e298eab4f (patch)
tree584a468097b708d7c15a654defa66648452fec38 /dev-python
parentdev-python/statsmodels: Bump to 0.14.3 (diff)
downloadgentoo-eaecb21abd5d1a1ee389a147d2f44e5e298eab4f.tar.gz
gentoo-eaecb21abd5d1a1ee389a147d2f44e5e298eab4f.tar.bz2
gentoo-eaecb21abd5d1a1ee389a147d2f44e5e298eab4f.zip
dev-python/cfn-lint: Bump to 1.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.14.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 5da833f64b46..c9577fac7229 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn_lint-1.11.1.tar.gz 2415408 BLAKE2B c164f6cd520e4106ff9cfaaffdcb66860c3e66060aad484a488f22a304c56c5a365389e63f948d647e37e10ead5f6c8e5bb435c842377e4db122805d7bab218c SHA512 c8295874345b2a561e521b732031558ff4d1de11fcd912940955301f0c4d1923d11d7d8f2cf5a90c3c540d3b28dbcd9f18fb01778fa9678e3fe6722d732d4014
DIST cfn_lint-1.12.4.tar.gz 2870663 BLAKE2B 90b1c2682a143108f077b1239171cb410657a33f1970e1f9fbc06774d1301ad0c28e364d7cf60163cb1d62a3c24221595e722db1fda5b79aebfd4fb321008396 SHA512 04092142a5de5da4cf2e94fe425c696cee3fd438fb569faa16bd390f3f3b8bfee63397a2aeedca99950eb656916b04456d59f2069c8479ce4c8acdffae01018a
DIST cfn_lint-1.13.0.tar.gz 2378100 BLAKE2B a1fa12fe13df1f3f8c5e533c138036df7e2eae325641e7fd66a050a3bb81718caf353d867bf7bbc765942a93bb9025a97bd9691a5759f59118296c23daf7466e SHA512 eeec69657907cc145e533c390987f25374e9019a4c493d3a8ad98123f8db9445bac4890cbaef59b15af752d5a3437f75ea1687bc167198aec81ebb0a3c1ab097
+DIST cfn_lint-1.14.0.tar.gz 2380297 BLAKE2B 27c72256f5ca353e40adb22c90754e37624962529a07e5f7b2af06a3c270d9a6b6e9721b1906de8992363dd42b66cba1b11f9e3c0f09e02cbd8c6f202f24eda8 SHA512 708d7776bc45bd5da722fda30b028f9ce403384ff584b0ea0aca47e1a002ddbb53845dc33db23ddb91e1b2984aee2a3c992c47357622c80a2954a9327c17ebae
diff --git a/dev-python/cfn-lint/cfn-lint-1.14.0.ebuild b/dev-python/cfn-lint/cfn-lint-1.14.0.ebuild
new file mode 100644
index 000000000000..086f03ea08df
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.14.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.91.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}