summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-15 18:34:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-15 20:30:48 +0200
commit55e8c29985e925e103a5a50b8b37ad5edda9770a (patch)
tree643a6ca822419b17596c286ded30122f4fac722e /dev-python
parentdev-python/nanobind: Fix parallel build failure (diff)
downloadgentoo-55e8c29985e925e103a5a50b8b37ad5edda9770a.tar.gz
gentoo-55e8c29985e925e103a5a50b8b37ad5edda9770a.tar.bz2
gentoo-55e8c29985e925e103a5a50b8b37ad5edda9770a.zip
dev-python/nanobind: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nanobind/Manifest1
-rw-r--r--dev-python/nanobind/nanobind-2.1.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/nanobind/Manifest b/dev-python/nanobind/Manifest
index 779583f66f8b..79f670abf956 100644
--- a/dev-python/nanobind/Manifest
+++ b/dev-python/nanobind/Manifest
@@ -1 +1,2 @@
DIST nanobind-2.0.0.gh.tar.gz 842956 BLAKE2B 82a2b44d904a2bfc88538d3bac6d5d96b473bcca2ff98647f9edd656a1d20fae324fcf334b848f861723aae666690b6b17ee626dede89bac6b140e9ef8cd01fe SHA512 1bafbf6b18c9b65b5ecb3bbf23a164b17ee52ef4f053a00de986a35e17e662422b54cea1c145f83ee8a3973bba383a949b3c305dcfecfbf139ab90006d42935e
+DIST nanobind-2.1.0.gh.tar.gz 850714 BLAKE2B 5686c0b204904d22e306338f0cf62f0ac306165510f94bfe94d6a36f8294ea108f2f195c67b5314476e9bc3083292c69974c52889015e2ac6cb996a0fbcfbaff SHA512 1aaca50f8253b1b831e1d7092cfb238a020f72b7ae9830b04ecaff519a38dbe1396f79aac3098d942f30e7bb372862a2473459adbab898f17683ee488a0dad87
diff --git a/dev-python/nanobind/nanobind-2.1.0.ebuild b/dev-python/nanobind/nanobind-2.1.0.ebuild
new file mode 100644
index 000000000000..6a01b59dbefb
--- /dev/null
+++ b/dev-python/nanobind/nanobind-2.1.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=scikit-build-core
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit cmake distutils-r1
+
+DESCRIPTION="Tiny and efficient C++/Python bindings"
+HOMEPAGE="
+ https://github.com/wjakob/nanobind
+ https://pypi.org/project/nanobind/
+"
+SRC_URI="
+ https://github.com/wjakob/nanobind/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv"
+
+DEPEND="
+ >=dev-cpp/robin-map-1.3.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ # simplified version of https://github.com/wjakob/nanobind/pull/718
+ "${FILESDIR}/${PN}-2.0.0-parallel-build.patch"
+ )
+
+ cmake_src_prepare
+ PATCHES=()
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ # XXX: nanobind installs a CMake config file which by default passes -Os
+ # We currently patch around it in dev-python/pyopencl. In future, we
+ # may want to add some override with Gentoo specific environment vars.
+ DISTUTILS_ARGS=(
+ -DNB_CREATE_INSTALL_RULES=ON
+ -DNB_USE_SUBMODULE_DEPS=OFF
+ -DNB_TEST=OFF
+ )
+}
+
+python_test() {
+ local mycmakeargs=(
+ -DNB_CREATE_INSTALL_RULES=OFF
+ -DNB_USE_SUBMODULE_DEPS=OFF
+ -DNB_TEST=ON
+ )
+ cmake_src_configure
+ cmake_src_compile
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ cd "${BUILD_DIR}/tests" || die
+ epytest
+}