summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-15 18:26:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-15 20:30:48 +0200
commitec2568492a586ff3139ad891c403d968c11022a7 (patch)
tree57ae8ef32eac9c1e48a2c3acdea09970e466c4e7 /dev-python
parentdev-python/python-tests: Stabilize 3.10.15 arm64, #939209 (diff)
downloadgentoo-ec2568492a586ff3139ad891c403d968c11022a7.tar.gz
gentoo-ec2568492a586ff3139ad891c403d968c11022a7.tar.bz2
gentoo-ec2568492a586ff3139ad891c403d968c11022a7.zip
dev-python/nanobind: Fix parallel build failure
Closes: https://bugs.gentoo.org/936552 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nanobind/files/nanobind-2.0.0-parallel-build.patch7
-rw-r--r--dev-python/nanobind/nanobind-2.0.0-r1.ebuild6
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/nanobind/files/nanobind-2.0.0-parallel-build.patch b/dev-python/nanobind/files/nanobind-2.0.0-parallel-build.patch
new file mode 100644
index 000000000000..d64c7383b976
--- /dev/null
+++ b/dev-python/nanobind/files/nanobind-2.0.0-parallel-build.patch
@@ -0,0 +1,7 @@
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 62f2bdb..e932cca 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -75 +75 @@ nanobind_add_stub(
+- DEPENDS py_stub_test.py
++ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/py_stub_test.py
diff --git a/dev-python/nanobind/nanobind-2.0.0-r1.ebuild b/dev-python/nanobind/nanobind-2.0.0-r1.ebuild
index b8dacc8d3b5e..45dce8c57782 100644
--- a/dev-python/nanobind/nanobind-2.0.0-r1.ebuild
+++ b/dev-python/nanobind/nanobind-2.0.0-r1.ebuild
@@ -34,11 +34,17 @@ EPYTEST_XDIST=1
distutils_enable_tests pytest
python_prepare_all() {
+ local PATCHES=(
+ # simplified version of https://github.com/wjakob/nanobind/pull/718
+ "${FILESDIR}/${PN}-2.0.0-parallel-build.patch"
+ )
+
# This test assumes in-source build for the .pyi stubs.
# (Hack because EPYTEST_IGNORE doesn't work with the paths it collects(?))
echo > tests/test_stubs.py || die
cmake_src_prepare
+ PATCHES=()
distutils-r1_python_prepare_all
}