summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-07 18:27:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-07 23:51:39 +0100
commitd7c04b3834d01aac9951ef15d306b0f64674ff5e (patch)
tree45a38e1e75ea14ce79469c28a13f731e6d7aebd5 /dev-python/audioread
parentdev-python/audioread: 2.1.8 version bump (diff)
downloadgentoo-d7c04b3834d01aac9951ef15d306b0f64674ff5e.tar.gz
gentoo-d7c04b3834d01aac9951ef15d306b0f64674ff5e.tar.bz2
gentoo-d7c04b3834d01aac9951ef15d306b0f64674ff5e.zip
dev-python/audioread: Drop 1.0.1-r1
Package-Manager: Portage-2.3.81, Repoman-2.3.19 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/audioread')
-rw-r--r--dev-python/audioread/Manifest1
-rw-r--r--dev-python/audioread/audioread-1.0.1-r1.ebuild31
-rw-r--r--dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch30
3 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/audioread/Manifest b/dev-python/audioread/Manifest
index 8c6fae0cf09a..8f5f4d9ac4d0 100644
--- a/dev-python/audioread/Manifest
+++ b/dev-python/audioread/Manifest
@@ -1,2 +1 @@
-DIST audioread-1.0.1.tar.gz 13004 BLAKE2B e2741e43904ab3eba821118163d019bc336fafc157c0a5ab7ccf09c2622d395da104232d5276fda32cd7e945a4b66279ee028bde502e2359fa58c210b5af7804 SHA512 18e9e696785fe2f1b1d6ad7fe64e2878bf490d72aef7500998bb48b0733b382cf0b171d26c5b1465947de1d5f6ded25e2b57947402c31a440e8f346722fdc533
DIST audioread-2.1.8.tar.gz 21222 BLAKE2B 78cc55d45dd987fbe0171cd3da9f8441e38b60fa6f1b0ef8b0781abc91e6b447b8cf839437b59bfafdf13ca90bb50a032788e0470250f303122a46ddc24ebd19 SHA512 9db5ad1f8b2047256b5f6b4bbee2366043ed19d35ffd2766ae3ab66bdc5b9f63910bcf449fd42aab074fd8132642bf730c432aa0c8f3c5368cd6ef36d7f4f5a5
diff --git a/dev-python/audioread/audioread-1.0.1-r1.ebuild b/dev-python/audioread/audioread-1.0.1-r1.ebuild
deleted file mode 100644
index 8c7ced9e7c9d..000000000000
--- a/dev-python/audioread/audioread-1.0.1-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Module for decoding audio files using whichever backend is available"
-HOMEPAGE="https://pypi.org/project/audioread/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="|| ( dev-python/pymad media-video/ffmpeg )"
-
-PATCHES=(
- "${FILESDIR}/0001-Use-the-print-function-instead-of-the-print-keyword.patch"
- )
-
-pkg_postinst() {
- einfo "You might need to enable additional USE flags in backends to"
- einfo "decode some types of audio files. Priority of backends:"
- einfo " * mad"
- einfo " * ffmpeg"
-}
diff --git a/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch b/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
deleted file mode 100644
index 8feb9d0ca9b6..000000000000
--- a/dev-python/audioread/files/0001-Use-the-print-function-instead-of-the-print-keyword.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 3f86133d37d5cc5c8712730de67c23b0d33ce082 Mon Sep 17 00:00:00 2001
-From: Simon Chopin <chopin.simon@gmail.com>
-Date: Tue, 14 May 2013 12:46:50 +0200
-Subject: [PATCH] Use the print() function instead of the print keyword
-
-Python3 doesn't have the `print foo` statement.
----
- audioread/gstdec.py | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/audioread/gstdec.py b/audioread/gstdec.py
-index 78285db..fa8078f 100644
---- a/audioread/gstdec.py
-+++ b/audioread/gstdec.py
-@@ -366,8 +366,8 @@ if __name__ == '__main__':
- for path in sys.argv[1:]:
- path = os.path.abspath(os.path.expanduser(path))
- with GstAudioFile(path) as f:
-- print f.channels
-- print f.samplerate
-- print f.duration
-+ print(f.channels)
-+ print(f.samplerate)
-+ print(f.duration)
- for s in f:
-- print len(s), ord(s[0])
-+ print(len(s), ord(s[0]))
---
-1.8.1.5
-