summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-07 18:25:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-07 23:51:38 +0100
commit58157d700c9dc248693f5b3c4c529132184df6cf (patch)
treee129f72fd709f59221c5c3dd8f5ec4800c4a9672 /dev-python/audioread
parentsci-astronomy/pyephem: Drop 3.7.5.3 and 3.7.6.0 (r0) (diff)
downloadgentoo-58157d700c9dc248693f5b3c4c529132184df6cf.tar.gz
gentoo-58157d700c9dc248693f5b3c4c529132184df6cf.tar.bz2
gentoo-58157d700c9dc248693f5b3c4c529132184df6cf.zip
dev-python/audioread: 2.1.8 version bump
Package-Manager: Portage-2.3.81, Repoman-2.3.19 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/audioread')
-rw-r--r--dev-python/audioread/Manifest1
-rw-r--r--dev-python/audioread/audioread-2.1.8.ebuild48
-rw-r--r--dev-python/audioread/files/audioread-2.1.8-test-deps.patch27
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/audioread/Manifest b/dev-python/audioread/Manifest
index 7608b16acbb9..8c6fae0cf09a 100644
--- a/dev-python/audioread/Manifest
+++ b/dev-python/audioread/Manifest
@@ -1 +1,2 @@
DIST audioread-1.0.1.tar.gz 13004 BLAKE2B e2741e43904ab3eba821118163d019bc336fafc157c0a5ab7ccf09c2622d395da104232d5276fda32cd7e945a4b66279ee028bde502e2359fa58c210b5af7804 SHA512 18e9e696785fe2f1b1d6ad7fe64e2878bf490d72aef7500998bb48b0733b382cf0b171d26c5b1465947de1d5f6ded25e2b57947402c31a440e8f346722fdc533
+DIST audioread-2.1.8.tar.gz 21222 BLAKE2B 78cc55d45dd987fbe0171cd3da9f8441e38b60fa6f1b0ef8b0781abc91e6b447b8cf839437b59bfafdf13ca90bb50a032788e0470250f303122a46ddc24ebd19 SHA512 9db5ad1f8b2047256b5f6b4bbee2366043ed19d35ffd2766ae3ab66bdc5b9f63910bcf449fd42aab074fd8132642bf730c432aa0c8f3c5368cd6ef36d7f4f5a5
diff --git a/dev-python/audioread/audioread-2.1.8.ebuild b/dev-python/audioread/audioread-2.1.8.ebuild
new file mode 100644
index 000000000000..f21eb33892d3
--- /dev/null
+++ b/dev-python/audioread/audioread-2.1.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Wrapper for audio file decoding using FFmpeg or GStreamer"
+HOMEPAGE="https://pypi.org/project/audioread/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ || (
+ (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0
+ media-plugins/gst-plugins-meta:1.0
+ )
+ virtual/ffmpeg
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}/${P}-test-deps.patch" ) # git master
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "/'pytest-runner'/d" -i setup.py || die
+}
+
+pkg_postinst() {
+ einfo "You may need to emerge additional GStreamer plugins or enable"
+ einfo "additional USE flags in media-video/ffmpeg to decode some types"
+ einfo "of audio files."
+}
diff --git a/dev-python/audioread/files/audioread-2.1.8-test-deps.patch b/dev-python/audioread/files/audioread-2.1.8-test-deps.patch
new file mode 100644
index 000000000000..0a67767070b1
--- /dev/null
+++ b/dev-python/audioread/files/audioread-2.1.8-test-deps.patch
@@ -0,0 +1,27 @@
+From 5dd6c87a53f3a6c5bfa6ea384598213c49402056 Mon Sep 17 00:00:00 2001
+From: Glen Baker <iepathos@gmail.com>
+Date: Mon, 5 Aug 2019 23:40:27 -0700
+Subject: [PATCH] Correct pytest-runner location in setup.py
+
+Moved pytest-runner from setup_requires to tests_require. It is the tests that require pytest-runner.
+---
+ setup.py | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index bd90605..6041f6e 100644
+--- a/setup.py
++++ b/setup.py
+@@ -36,11 +36,8 @@ def _read(fn):
+
+ packages=['audioread'],
+
+- setup_requires=[
+- 'pytest-runner'
+- ],
+-
+ tests_require=[
++ 'pytest-runner',
+ 'pytest'
+ ],
+