aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-27 03:08:26 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-27 03:09:40 +0300
commit2268e58d2c0e577d6c35c4eb1683cb7fce0be95d (patch)
treecf1e71c67c09a43c975a7b63f6c12866e80e3712 /x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild
parentmedia-libs/libjxl: remove static lib, add todo (diff)
downloadguru-2268e58d2c0e577d6c35c4eb1683cb7fce0be95d.tar.gz
guru-2268e58d2c0e577d6c35c4eb1683cb7fce0be95d.tar.bz2
guru-2268e58d2c0e577d6c35c4eb1683cb7fce0be95d.zip
x11-libs/gtk-fortran: change version numbering. Add SLOT
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild')
-rw-r--r--x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild b/x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild
new file mode 100644
index 000000000..e0c095bfb
--- /dev/null
+++ b/x11-libs/gtk-fortran/gtk-fortran-3.24.18.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+FORTRAN_STANDARD=2003
+
+inherit cmake fortran-2
+
+DESCRIPTION="A GTK+ binding to build Graphical User Interfaces in Fortran"
+HOMEPAGE="https://github.com/vmagnin/gtk-fortran"
+SRC_URI="https://github.com/vmagnin/${PN}/archive/v20.04.gtk${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-20.04.gtk${PV}"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples high-level plplot static-libs"
+REQUIRED_USE="plplot? ( high-level )"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ plplot? ( >=sci-libs/plplot-5.13.0[cairo,fortran] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/fortran
+ virtual/pkgconfig
+"
+
+DOCS=( "README.md" "README-high-level.md" "CHANGELOG.md" )
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ # Fix library installation path and disable 'sketcher' build
+ sed -i -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):" \
+ -e "s: add_subdirectory(sketcher)::" CMakeLists.txt || die
+
+ use !static-libs && eapply "${FILESDIR}/${P}_skip-static-build.patch"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DEXCLUDE_PLPLOT=$(usex plplot false true)
+ -DNO_BUILD_HL=$(usex high-level false true)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ -DNO_BUILD_EXAMPLES=true
+ )
+ cmake_src_configure
+}