summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-07-09 09:44:57 +0000
committerMarius Mauch <genone@gentoo.org>2004-07-09 09:44:57 +0000
commita98557350fde5a790ce35f98be089c2c609aafdc (patch)
treedc50c81d8a77ff5b24a9e51e490872d5810b6eb9 /sys-libs
parentInitial import. Thanks for submission to Tobias Klausmann. (diff)
downloadhistorical-a98557350fde5a790ce35f98be089c2c609aafdc.tar.gz
historical-a98557350fde5a790ce35f98be089c2c609aafdc.tar.bz2
historical-a98557350fde5a790ce35f98be089c2c609aafdc.zip
adding a check for a f***** catalyst vardb, removing wrong return statement in pkg_setup
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r9.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r5.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r10.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r2.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r9.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.3.20040420.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040605.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619.ebuild27
11 files changed, 154 insertions, 143 deletions
diff --git a/sys-libs/glibc/glibc-2.2.5-r9.ebuild b/sys-libs/glibc/glibc-2.2.5-r9.ebuild
index 385c741f9e6f..8ccf1a717f5e 100644
--- a/sys-libs/glibc/glibc-2.2.5-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r9.ebuild,v 1.7 2004/07/05 01:24:31 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r9.ebuild,v 1.8 2004/07/09 09:44:57 genone Exp $
inherit flag-o-matic gcc eutils
@@ -65,18 +65,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.1-r5.ebuild b/sys-libs/glibc/glibc-2.3.1-r5.ebuild
index 4d41548da359..c1feba78bf76 100644
--- a/sys-libs/glibc/glibc-2.3.1-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r5.ebuild,v 1.12 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r5.ebuild,v 1.13 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build debug"
@@ -69,18 +69,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.2-r10.ebuild b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
index d268df7ea785..67aa9e154cda 100644
--- a/sys-libs/glibc/glibc-2.3.2-r10.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.17 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.18 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl debug"
@@ -168,18 +168,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.2-r2.ebuild b/sys-libs/glibc/glibc-2.3.2-r2.ebuild
index d8784de2f579..bf368f7a97cd 100644
--- a/sys-libs/glibc/glibc-2.3.2-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r2.ebuild,v 1.24 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r2.ebuild,v 1.25 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl debug"
@@ -198,18 +198,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.2-r9.ebuild b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
index bbed8be1cb70..473d28e6275f 100644
--- a/sys-libs/glibc/glibc-2.3.2-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.30 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.31 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl debug"
@@ -169,18 +169,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.3.20040420.ebuild b/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
index 488e583210a5..69d1c3c10127 100644
--- a/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420.ebuild,v 1.11 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420.ebuild,v 1.12 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl erandom debug"
@@ -170,18 +170,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild
index 8b4ca48e1f92..1c6de5481911 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild,v 1.15 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild,v 1.16 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl debug"
@@ -168,18 +168,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
index a95d886052ff..b2679b783ef2 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild,v 1.12 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild,v 1.13 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl debug"
@@ -168,18 +168,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild
index 70243729781c..6c0a4be73f69 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild,v 1.12 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild,v 1.13 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
@@ -208,18 +208,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.4.20040605.ebuild b/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
index 7c1096e376c8..08c80b3993e4 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605.ebuild,v 1.20 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605.ebuild,v 1.21 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
@@ -193,18 +193,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
index f78b59ae2642..6fed1e64deea 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619.ebuild,v 1.8 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619.ebuild,v 1.9 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
@@ -287,18 +287,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi