summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
index a95d886052ff..b2679b783ef2 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild,v 1.12 2004/07/08 22:24:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild,v 1.13 2004/07/09 09:44:57 genone Exp $
IUSE="nls pic build nptl debug"
@@ -168,18 +168,19 @@ pkg_setup() {
old_version="`best_version glibc`"
old_version="${old_version/sys-libs\/glibc-/}"
- if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
- if [ "${FORCE_DOWNGRADE}" ]; then
- ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
- return 0
- else
- eerror "Dowgrading glibc is not supported and we strongly recommend that"
- eerror "you don't do it as it WILL break all applications compiled against"
- eerror "the new version (most likely including python and portage)."
- eerror "If you are REALLY sure that you want to do it set "
- eerror " FORCE_DOWNGRADE=1"
- eerror "when you try it again."
- die "glibc downgrade"
+ if [ "$old_version" ]; then
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
fi
fi