summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-03-09 15:48:51 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-03-09 15:48:51 +0000
commit52fa301eb677ed29a304e55aa5f88fe62d636b32 (patch)
tree6d5ba037973d2350af6ae66bc9788e79912a5ae8 /sci-biology/mummer/mummer-3.21.ebuild
parentFixes symlink attack (#250554), sets CC (#243660), CFLAGS (#240078) and insta... (diff)
downloadhistorical-52fa301eb677ed29a304e55aa5f88fe62d636b32.tar.gz
historical-52fa301eb677ed29a304e55aa5f88fe62d636b32.tar.bz2
historical-52fa301eb677ed29a304e55aa5f88fe62d636b32.zip
QA fixes
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64
Diffstat (limited to 'sci-biology/mummer/mummer-3.21.ebuild')
-rw-r--r--sci-biology/mummer/mummer-3.21.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sci-biology/mummer/mummer-3.21.ebuild b/sci-biology/mummer/mummer-3.21.ebuild
index 7f0061d50651..dbf16cb8728f 100644
--- a/sci-biology/mummer/mummer-3.21.ebuild
+++ b/sci-biology/mummer/mummer-3.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/mummer-3.21.ebuild,v 1.1 2009/03/09 15:29:37 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/mummer-3.21.ebuild,v 1.2 2009/03/09 15:48:51 weaver Exp $
inherit eutils
@@ -19,6 +19,13 @@ RDEPEND=""
S="${WORKDIR}/${MY_P}"
+src_unpack() {
+ unpack ${A}
+ # Warning: package uses CPPFLAGS on c in addition to cpp, despite the name
+ sed -i -e 's/CPPFLAGS =/CPPFLAGS = ${CFLAGS} /' \
+ -e 's/LDFLAGS =$//' "${S}/Makefile"
+}
+
src_compile() {
emake || die "emake failed"