summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 19:25:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 19:25:39 +0000
commit05fc9e4d2b77fad41da718f70eb5e727f46af153 (patch)
tree5010ca23091159e707d4945948817d14e94c4286 /dev-python/subvertpy
parentReadded test (diff)
downloadhistorical-05fc9e4d2b77fad41da718f70eb5e727f46af153.tar.gz
historical-05fc9e4d2b77fad41da718f70eb5e727f46af153.tar.bz2
historical-05fc9e4d2b77fad41da718f70eb5e727f46af153.zip
Simplify src_test().
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-python/subvertpy')
-rw-r--r--dev-python/subvertpy/Manifest2
-rw-r--r--dev-python/subvertpy/subvertpy-0.7.2.ebuild24
2 files changed, 12 insertions, 14 deletions
diff --git a/dev-python/subvertpy/Manifest b/dev-python/subvertpy/Manifest
index 13113ebbf545..5ec76dca215f 100644
--- a/dev-python/subvertpy/Manifest
+++ b/dev-python/subvertpy/Manifest
@@ -1,4 +1,4 @@
DIST subvertpy-0.7.2.tar.gz 80627 RMD160 b57be7948eb87bed7861c23ed3da5bf8c070eb73 SHA1 f8eb472084d771eb1ae7a67517ecd1061d548759 SHA256 817300e4cadb02fb89903028eaf7d128b274fe3c2808c76917b5adfe5b9687a3
-EBUILD subvertpy-0.7.2.ebuild 1094 RMD160 88fcfe0bcfa5981ee46543753746fd46750999d7 SHA1 0ee86e1ad856cb76751b5ffcde46bd9cf648452c SHA256 b427df9e07d486f683569e7cc2ecc969f31c3491867150139167de5d3ba7b1cf
+EBUILD subvertpy-0.7.2.ebuild 1076 RMD160 217bdda656b775468cc9f654a94ca7e1e9fa57dc SHA1 4c8132a867a4108cee4d1883a0833ad9d66bed37 SHA256 91cabee26e4dcc026347796b3dd89986f7c023e6eb7ec4ebc081b2ac20d88d0a
MISC ChangeLog 2023 RMD160 08eee779b4f25ab26442c2295ac9b6dfbb01dc93 SHA1 a7345e76960374f5eada51d4f009bc17c3be93fb SHA256 926b9d13ad458bd36672c7659caed69e4ff60f0bd847f4f066ab04f932d9ac4b
MISC metadata.xml 270 RMD160 0784825b3037e27bf8f06ffabba9783ecdd1d33d SHA1 5e097fe7035086b5c30f963ddac2a1df5062f619 SHA256 758061f2c796a31ce3126c4733ca1c9e8c9cadd3aea51640386d929af7f74d06
diff --git a/dev-python/subvertpy/subvertpy-0.7.2.ebuild b/dev-python/subvertpy/subvertpy-0.7.2.ebuild
index ce54d2e8a24c..e17873acc145 100644
--- a/dev-python/subvertpy/subvertpy-0.7.2.ebuild
+++ b/dev-python/subvertpy/subvertpy-0.7.2.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.7.2.ebuild,v 1.5 2010/06/22 18:38:12 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.7.2.ebuild,v 1.6 2010/06/28 19:25:39 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -21,18 +23,14 @@ RDEPEND=">=dev-vcs/subversion-1.4
!<dev-util/bzr-svn-0.5.0_rc2"
DEPEND="${RDEPEND}
test? ( dev-python/nose )"
-RESTRICT_PYTHON_ABIS="3.*"
-DOCS="NEWS AUTHORS"
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-src_test() {
- testing() {
- local module
- for module in _ra client repos wc; do
- ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with Python ${PYTHON_ABI}"
- done
+DOCS="NEWS AUTHORS"
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests
- }
- python_execute_function testing
+distutils_src_test_pre_hook() {
+ local module
+ for module in _ra client repos wc; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with Python ${PYTHON_ABI}"
+ done
}