summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/subvertpy/subvertpy-0.7.2.ebuild')
-rw-r--r--dev-python/subvertpy/subvertpy-0.7.2.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/dev-python/subvertpy/subvertpy-0.7.2.ebuild b/dev-python/subvertpy/subvertpy-0.7.2.ebuild
index ce54d2e8a24c..e17873acc145 100644
--- a/dev-python/subvertpy/subvertpy-0.7.2.ebuild
+++ b/dev-python/subvertpy/subvertpy-0.7.2.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.7.2.ebuild,v 1.5 2010/06/22 18:38:12 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.7.2.ebuild,v 1.6 2010/06/28 19:25:39 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -21,18 +23,14 @@ RDEPEND=">=dev-vcs/subversion-1.4
!<dev-util/bzr-svn-0.5.0_rc2"
DEPEND="${RDEPEND}
test? ( dev-python/nose )"
-RESTRICT_PYTHON_ABIS="3.*"
-DOCS="NEWS AUTHORS"
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-src_test() {
- testing() {
- local module
- for module in _ra client repos wc; do
- ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with Python ${PYTHON_ABI}"
- done
+DOCS="NEWS AUTHORS"
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests
- }
- python_execute_function testing
+distutils_src_test_pre_hook() {
+ local module
+ for module in _ra client repos wc; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with Python ${PYTHON_ABI}"
+ done
}