summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild b/dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild
new file mode 100644
index 000000000000..d8c9f06fe489
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.006
+inherit perl-module
+
+DESCRIPTION="Receive notification when something changes a file's contents"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Digest-MD5
+ >=dev-perl/Dist-Zilla-4.300.39
+ virtual/perl-Encode
+ dev-perl/Moose
+ dev-perl/Safe-Isa
+ dev-perl/namespace-autoclean
+"
+DEPEND="
+ dev-perl/Module-Build-Tiny
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.39.0
+ test? (
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-File-Spec
+ dev-perl/Module-Runtime
+ dev-perl/Path-Tiny
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-if
+ )
+"