summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-01 13:45:48 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-04 02:47:56 +1200
commitbdd96b6e09451cbf70f924097b7cefe753915d90 (patch)
tree83adf07103e3c0a08d96f4194a6c2b51630212b7 /dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild
parentdev-perl/Dist-Zilla-Plugin-CheckChangesHasContent: Add w/v=0.11.0 (diff)
downloadgentoo-bdd96b6e09451cbf70f924097b7cefe753915d90.tar.gz
gentoo-bdd96b6e09451cbf70f924097b7cefe753915d90.tar.bz2
gentoo-bdd96b6e09451cbf70f924097b7cefe753915d90.zip
dev-perl/Dist-Zilla-Role-FileWatcher: Add w/v=0.6.0
Required by: - dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod - via dev-perl/Dist-Zilla-Plugin-CopyFilesFromBuild (test) - via dev-perl/Dist-Milla And Dist-Milla may be useful for building dev-perl/App-cpanminus from git Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild b/dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild
new file mode 100644
index 000000000000..d8c9f06fe489
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Role-FileWatcher/Dist-Zilla-Role-FileWatcher-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.006
+inherit perl-module
+
+DESCRIPTION="Receive notification when something changes a file's contents"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Digest-MD5
+ >=dev-perl/Dist-Zilla-4.300.39
+ virtual/perl-Encode
+ dev-perl/Moose
+ dev-perl/Safe-Isa
+ dev-perl/namespace-autoclean
+"
+DEPEND="
+ dev-perl/Module-Build-Tiny
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.39.0
+ test? (
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-File-Spec
+ dev-perl/Module-Runtime
+ dev-perl/Path-Tiny
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-if
+ )
+"