summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-02-21 19:19:40 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-02-21 19:20:00 +0300
commite62617ffb1b60e2a916b7a92659df2606374d62a (patch)
tree2ac4229c2a4e5f128eef6963eb76147128e77de1 /sci-chemistry
parentsci-chemistry/votca: fix python dep (diff)
downloadgentoo-e62617ffb1b60e2a916b7a92659df2606374d62a.tar.gz
gentoo-e62617ffb1b60e2a916b7a92659df2606374d62a.tar.bz2
gentoo-e62617ffb1b60e2a916b7a92659df2606374d62a.zip
sci-chemistry/gromacs: Fix musl build (missing int64_t) for 2022
Closes: https://bugs.gentoo.org/833599 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gromacs/files/gromacs-2022-musl-stdint.patch25
-rw-r--r--sci-chemistry/gromacs/gromacs-2022_rc1-r2.ebuild (renamed from sci-chemistry/gromacs/gromacs-2022_rc1-r1.ebuild)2
2 files changed, 27 insertions, 0 deletions
diff --git a/sci-chemistry/gromacs/files/gromacs-2022-musl-stdint.patch b/sci-chemistry/gromacs/files/gromacs-2022-musl-stdint.patch
new file mode 100644
index 000000000000..cae6fff93ae3
--- /dev/null
+++ b/sci-chemistry/gromacs/files/gromacs-2022-musl-stdint.patch
@@ -0,0 +1,25 @@
+From 694994a9d8ad989e7c5d61b7759024a7b10ce3b7 Mon Sep 17 00:00:00 2001
+From: Paul Bauer <paul.bauer.q@gmail.com>
+Date: Mon, 21 Feb 2022 09:53:46 +0100
+Subject: [PATCH 1/6] Fix missing includes for musl libc
+
+Fixes #4404
+---
+ api/legacy/include/gromacs/math/vectypes.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/api/legacy/include/gromacs/math/vectypes.h b/api/legacy/include/gromacs/math/vectypes.h
+index b818f5f8f8..7c5457e05d 100644
+--- a/api/legacy/include/gromacs/math/vectypes.h
++++ b/api/legacy/include/gromacs/math/vectypes.h
+@@ -36,6 +36,7 @@
+
+ #include <cassert>
+ #include <cmath>
++#include <cstdint>
+
+ #include <algorithm>
+ #include <type_traits>
+--
+2.35.1
+
diff --git a/sci-chemistry/gromacs/gromacs-2022_rc1-r1.ebuild b/sci-chemistry/gromacs/gromacs-2022_rc1-r2.ebuild
index f12ac52a719f..b0d42eda5cb0 100644
--- a/sci-chemistry/gromacs/gromacs-2022_rc1-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022_rc1-r2.ebuild
@@ -82,6 +82,8 @@ DOCS=( AUTHORS README )
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${PN}-2022-musl-stdint.patch" )
+
if [[ ${PV} != *9999 ]]; then
S="${WORKDIR}/${PN}-${PV/_/-}"
fi