summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2022-02-21 09:18:20 -0700
committerChristoph Junghans <junghans@gentoo.org>2022-02-21 09:18:36 -0700
commit24d49d50d85c465cabe555d7185fc9f1eed12a59 (patch)
tree577cb5520e522e8841b99e37d75603dad7fe299a /sci-chemistry
parentapp-crypt/yubikey-manager-4.0.8: get ready for enabling tests (diff)
downloadgentoo-24d49d50d85c465cabe555d7185fc9f1eed12a59.tar.gz
gentoo-24d49d50d85c465cabe555d7185fc9f1eed12a59.tar.bz2
gentoo-24d49d50d85c465cabe555d7185fc9f1eed12a59.zip
sci-chemistry/votca: fix python dep
Closes: https://bugs.gentoo.org/833818 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/votca/votca-2022.ebuild12
-rw-r--r--sci-chemistry/votca/votca-9999.ebuild12
2 files changed, 22 insertions, 2 deletions
diff --git a/sci-chemistry/votca/votca-2022.ebuild b/sci-chemistry/votca/votca-2022.ebuild
index a60728a6a6a9..0962e065f91d 100644
--- a/sci-chemistry/votca/votca-2022.ebuild
+++ b/sci-chemistry/votca/votca-2022.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
-inherit bash-completion-r1 cmake
+inherit bash-completion-r1 cmake python-single-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -25,12 +26,14 @@ HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+gromacs test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
RDEPEND="
!sci-libs/votca-tools
!sci-chemistry/votca-csg
!sci-chemistry/votca-xtp
+ ${PYTHON_DEPS}
app-shells/bash:*
>=dev-cpp/eigen-3.3
dev-libs/boost:=
@@ -47,6 +50,13 @@ BDEPEND="virtual/pkgconfig"
DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+src_prepare() {
+ # espressopp was removed from gentoo
+ rm -r ./csg-tutorials/spce/ibi_espressopp || die
+ python_fix_shebang .
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_TESTING=$(usex test)
diff --git a/sci-chemistry/votca/votca-9999.ebuild b/sci-chemistry/votca/votca-9999.ebuild
index a60728a6a6a9..0962e065f91d 100644
--- a/sci-chemistry/votca/votca-9999.ebuild
+++ b/sci-chemistry/votca/votca-9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
-inherit bash-completion-r1 cmake
+inherit bash-completion-r1 cmake python-single-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -25,12 +26,14 @@ HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+gromacs test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
RDEPEND="
!sci-libs/votca-tools
!sci-chemistry/votca-csg
!sci-chemistry/votca-xtp
+ ${PYTHON_DEPS}
app-shells/bash:*
>=dev-cpp/eigen-3.3
dev-libs/boost:=
@@ -47,6 +50,13 @@ BDEPEND="virtual/pkgconfig"
DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+src_prepare() {
+ # espressopp was removed from gentoo
+ rm -r ./csg-tutorials/spce/ibi_espressopp || die
+ python_fix_shebang .
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_TESTING=$(usex test)