summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 20:27:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 22:03:59 +0100
commit37a7f5532881b0f410b4434c51a84c30b82a6a6a (patch)
tree39417d6e051bd36afa911a6c33aac611779faa7e /kde-plasma/kwayland/kwayland-6.2.5.ebuild
parentkde-plasma/kwallet-pam: 6.2.5 version bump (diff)
downloadgentoo-37a7f5532881b0f410b4434c51a84c30b82a6a6a.tar.gz
gentoo-37a7f5532881b0f410b4434c51a84c30b82a6a6a.tar.bz2
gentoo-37a7f5532881b0f410b4434c51a84c30b82a6a6a.zip
kde-plasma/kwayland: 6.2.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland/kwayland-6.2.5.ebuild')
-rw-r--r--kde-plasma/kwayland/kwayland-6.2.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-plasma/kwayland/kwayland-6.2.5.ebuild b/kde-plasma/kwayland/kwayland-6.2.5.ebuild
new file mode 100644
index 000000000000..8e0973c35f15
--- /dev/null
+++ b/kde-plasma/kwayland/kwayland-6.2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.6.0
+QTMIN=6.7.2
+inherit ecm flag-o-matic plasma.kde.org
+
+DESCRIPTION="Qt-style API to interact with the wayland-client API"
+HOMEPAGE="https://invent.kde.org/frameworks/kwayland"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT="test"
+
+# slot ops: includes qpa/qplatformnativeinterface.h, surface_p.h
+RDEPEND="
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtbase-${QTMIN}:6=[concurrent,gui,opengl]
+ >=dev-qt/qtwayland-${QTMIN}:6=
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.14.0
+ >=dev-libs/wayland-protocols-1.15
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=dev-util/wayland-scanner-1.19.0
+"
+
+src_configure() {
+ filter-lto # bug 866575
+ ecm_src_configure
+}