summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 20:27:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 22:03:59 +0100
commit37a7f5532881b0f410b4434c51a84c30b82a6a6a (patch)
tree39417d6e051bd36afa911a6c33aac611779faa7e
parentkde-plasma/kwallet-pam: 6.2.5 version bump (diff)
downloadgentoo-37a7f5532881b0f410b4434c51a84c30b82a6a6a.tar.gz
gentoo-37a7f5532881b0f410b4434c51a84c30b82a6a6a.tar.bz2
gentoo-37a7f5532881b0f410b4434c51a84c30b82a6a6a.zip
kde-plasma/kwayland: 6.2.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kwayland/Manifest1
-rw-r--r--kde-plasma/kwayland/kwayland-6.2.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/kwayland/Manifest b/kde-plasma/kwayland/Manifest
index 89f711edee68..4927a2efb44b 100644
--- a/kde-plasma/kwayland/Manifest
+++ b/kde-plasma/kwayland/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-5.116.0.tar.xz 337540 BLAKE2B e238af4a122317fde2b207762858fb913005afde60f1b9cf2dfd90163021d8c3d7d9c3b055a4bb3ae26b5d0560e90c9e0d1e1e51480315bf1a5bc5592a231d11 SHA512 48b24c88872a21d237274868fea601120fb9700f888ab0a7531651dc6501db8559af3a70b6131d89d31010e1f32013222d42e9d1244ae91bf9972588494957a9
DIST kwayland-6.2.4.tar.xz 133964 BLAKE2B 4c4b560119b84ddee1db969b3fb5a6ea47e57702c9ddbed19ab0b2070395a05e983da1802ecef8ceffc5bad593d2dfaded45a503aa4a661b87e1dd48737fcc68 SHA512 1b18d4754cf1b8d3dc44470e3f95b1b4b9bee8337bdf8bf2506aa33fec640a09538bb162ce421bf607d2397035c04e11061eeb8473634a8d302976cc7d685128
+DIST kwayland-6.2.5.tar.xz 134116 BLAKE2B 2c3cfff31e795d3f7eda5158ca811ea2a9c989e907c6392bcbb40e17f896311a894549b965a9e552a254fe2380364f5c8d61f380a8f3c2b82896298e47690e18 SHA512 5c21be7b6ad89c99221b8f02e92f54125d39c7e83890398b0509d5b637af077c193b57b05ae7a814f77d39b4ba3692c36698306968072e28aeb3dc5e8bc546e6
diff --git a/kde-plasma/kwayland/kwayland-6.2.5.ebuild b/kde-plasma/kwayland/kwayland-6.2.5.ebuild
new file mode 100644
index 000000000000..8e0973c35f15
--- /dev/null
+++ b/kde-plasma/kwayland/kwayland-6.2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.6.0
+QTMIN=6.7.2
+inherit ecm flag-o-matic plasma.kde.org
+
+DESCRIPTION="Qt-style API to interact with the wayland-client API"
+HOMEPAGE="https://invent.kde.org/frameworks/kwayland"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT="test"
+
+# slot ops: includes qpa/qplatformnativeinterface.h, surface_p.h
+RDEPEND="
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtbase-${QTMIN}:6=[concurrent,gui,opengl]
+ >=dev-qt/qtwayland-${QTMIN}:6=
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.14.0
+ >=dev-libs/wayland-protocols-1.15
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=dev-util/wayland-scanner-1.19.0
+"
+
+src_configure() {
+ filter-lto # bug 866575
+ ecm_src_configure
+}