summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-30 03:51:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-30 03:53:48 +0200
commitd63c7599a871cbae55d829e2e7fe371d07ff6d83 (patch)
treee80a3760f0ec39bad4729b3d17055901cdedc152
parentdev-python/sphinx-autoapi: Bump to 3.3.0 (diff)
downloadgentoo-d63c7599a871cbae55d829e2e7fe371d07ff6d83.tar.gz
gentoo-d63c7599a871cbae55d829e2e7fe371d07ff6d83.tar.bz2
gentoo-d63c7599a871cbae55d829e2e7fe371d07ff6d83.zip
dev-python/jsondiff: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jsondiff/Manifest1
-rw-r--r--dev-python/jsondiff/jsondiff-2.2.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
index c3bf78f00cff..dd132e0a5662 100644
--- a/dev-python/jsondiff/Manifest
+++ b/dev-python/jsondiff/Manifest
@@ -1 +1,2 @@
DIST jsondiff-2.2.0.gh.tar.gz 22672 BLAKE2B 64af3c3f0aa9c7c6380af30ae303c230a04ba02d9e97d25b46348134312ea53d869e74c24a1b0d72983d731dda6d74a3fee3d89df6e9a6ef083321fe9b501ec3 SHA512 a1da92a1a38047947c2ee6057c641930c1b141889f992723c250a4444871170e2b10c892595a3bce026339b1d03c91d157cdf918fb36d4b916131bee5db969e5
+DIST jsondiff-2.2.1.gh.tar.gz 22715 BLAKE2B 598d999d6d2dd9a3a6abd8b34145420b2ee9c6b5bf4a686e1c4fe605d68c3ee588efda4db0a0127a13f10e4639b43661f297e83a314ee8a0c12e9408c8dfdcbb SHA512 e10ed1f1b11b877223936586c1805cb8b8ae3f487f913f4d33030ae6e87a06a54f1f9adfb2b50485d72123f2feb6b40aa019851a6c9fd83575cc0f0b814484f7
diff --git a/dev-python/jsondiff/jsondiff-2.2.1.ebuild b/dev-python/jsondiff/jsondiff-2.2.1.ebuild
new file mode 100644
index 000000000000..1f6ddda4fc90
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-2.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="
+ https://github.com/xlwings/jsondiff/
+ https://pypi.org/project/jsondiff/
+"
+SRC_URI="
+ https://github.com/xlwings/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}