summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-30 03:51:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-30 03:53:47 +0200
commitefff784a07b24978292efb69ffe9c7364ee222b7 (patch)
treedb9988993ad53c798bba7fcebd5bf13714e11c9a
parentdev-python/python-cinderclient: Bump to 9.6.0 (diff)
downloadgentoo-efff784a07b24978292efb69ffe9c7364ee222b7.tar.gz
gentoo-efff784a07b24978292efb69ffe9c7364ee222b7.tar.bz2
gentoo-efff784a07b24978292efb69ffe9c7364ee222b7.zip
dev-python/sphinx-autoapi: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-autoapi/Manifest1
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.3.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 04447c744e8b..e76f4eaa6dcc 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1 +1,2 @@
DIST sphinx-autoapi-3.2.1.gh.tar.gz 68891 BLAKE2B b31db0f584498a96d3bf7e57fa92abd884d3b8bb8812236a8491685f0fc81d212e114ae1663e316ba7ba14dee082dd4aeab19941f3d6ab85de95399f3736f596 SHA512 e1920a79ce8954a9da1d33fd46e5c1968990e5cfd960a8c97ac344d3d6dd97c06dbbafb3144e67d223f6504b233e0cf59328f015d918264df12b00aed8e34f8f
+DIST sphinx-autoapi-3.3.0.gh.tar.gz 70367 BLAKE2B 8e4efd0722b8ffff31816839b88fc1dadd0bbb10143a2361cd040f5bafa806d128b288a0acd77b9cc881c7e45a47e2802f666486f07f705d0aa0312ae840da9c SHA512 fec162717137ff71d196feeecdb84a3fa953471c06a0bf8a586cc5d5f6ecece09b6ac20928039e8cfbd4eeb060e6cf0c1e633ffed2509ad760f1796bd1e10a47
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.3.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.3.0.ebuild
new file mode 100644
index 000000000000..2dfb0a4c4c8b
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPEP695::test_integration
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}