summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-08-01 20:47:35 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-08-01 20:51:35 -0400
commit460c9353fcd87bc6dcd094d6e6326e05e40ce0c2 (patch)
tree62127b72454c877badb995dacd2f0480183c508f
parentmate-extra/caja-hide: Support python 3_9 (diff)
downloadgentoo-mate-460c9353fcd87bc6dcd094d6e6326e05e40ce0c2.tar.gz
gentoo-mate-460c9353fcd87bc6dcd094d6e6326e05e40ce0c2.tar.bz2
gentoo-mate-460c9353fcd87bc6dcd094d6e6326e05e40ce0c2.zip
app-editors/pluma: Support python 3_9, 3_10
Also fix path in src_test to avoid warning message Bug: https://bugs.gentoo.org/799668 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
-rw-r--r--app-editors/pluma/pluma-1.24.1.ebuild4
-rw-r--r--app-editors/pluma/pluma-1.24.2.ebuild4
-rw-r--r--app-editors/pluma/pluma-9999.ebuild6
3 files changed, 7 insertions, 7 deletions
diff --git a/app-editors/pluma/pluma-1.24.1.ebuild b/app-editors/pluma/pluma-1.24.1.ebuild
index 9add36a..0757d29 100644
--- a/app-editors/pluma/pluma-1.24.1.ebuild
+++ b/app-editors/pluma/pluma-1.24.1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
MATE_LA_PUNT="yes"
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+PYTHON_COMPAT=( python{3_7,3_8,3_9,3_10} )
inherit mate python-single-r1 virtualx
@@ -73,7 +73,7 @@ src_configure() {
src_test() {
# FIXME: This should be handled at eclass level.
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ "${EPREFIX%/}/${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
unset DBUS_SESSION_BUS_ADDRESS
diff --git a/app-editors/pluma/pluma-1.24.2.ebuild b/app-editors/pluma/pluma-1.24.2.ebuild
index 0614361..849ab40 100644
--- a/app-editors/pluma/pluma-1.24.2.ebuild
+++ b/app-editors/pluma/pluma-1.24.2.ebuild
@@ -5,7 +5,7 @@ EAPI=6
MATE_LA_PUNT="yes"
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9,3_10} )
inherit mate python-single-r1 virtualx
@@ -73,7 +73,7 @@ src_configure() {
src_test() {
# FIXME: This should be handled at eclass level.
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ "${EPREFIX%/}/${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
unset DBUS_SESSION_BUS_ADDRESS
diff --git a/app-editors/pluma/pluma-9999.ebuild b/app-editors/pluma/pluma-9999.ebuild
index 9d5382f..849ab40 100644
--- a/app-editors/pluma/pluma-9999.ebuild
+++ b/app-editors/pluma/pluma-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MATE_LA_PUNT="yes"
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9,3_10} )
inherit mate python-single-r1 virtualx
@@ -73,7 +73,7 @@ src_configure() {
src_test() {
# FIXME: This should be handled at eclass level.
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ "${EPREFIX%/}/${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
unset DBUS_SESSION_BUS_ADDRESS