summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/sox/sox-12.16.ebuild')
-rw-r--r--media-sound/sox/sox-12.16.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/sox/sox-12.16.ebuild b/media-sound/sox/sox-12.16.ebuild
new file mode 100644
index 000000000000..f4b38763bb02
--- /dev/null
+++ b/media-sound/sox/sox-12.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-12.16.ebuild,v 1.1 2000/08/15 21:24:56 achim Exp $
+
+P=sox-12.16
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="media-sound"
+DESCRIPTION="The swiss army knife of sound processing programs"
+SRC_URI="http://metalab.unc.edu/pub/Linux/apps/sound/convert/${A}"
+HOMEPAGE="http://home.sprynet.com/~cgabwell/sox.html"
+
+
+src_compile() {
+
+ cd ${S}
+ ./configure --prefix=/usr --host=${CHOST} \
+ --enable-fast-ulaw --enable-fast-alaw
+ make
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin sox
+ doman sox.1
+ dodoc CHEAT README sox.txt TIPS TODO
+
+}
+
+