summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/mpg123/files/digest1
-rw-r--r--media-sound/mpg123/mpg123-0.59r.ebuild39
-rw-r--r--media-sound/sox/files/digest1
-rw-r--r--media-sound/sox/sox-12.16.ebuild34
4 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/mpg123/files/digest b/media-sound/mpg123/files/digest
new file mode 100644
index 000000000000..86378835775d
--- /dev/null
+++ b/media-sound/mpg123/files/digest
@@ -0,0 +1 @@
+MD5 95df59ad1651dd2346d49fafc83747e7 mpg123-0.59r.tar.gz
diff --git a/media-sound/mpg123/mpg123-0.59r.ebuild b/media-sound/mpg123/mpg123-0.59r.ebuild
new file mode 100644
index 000000000000..28ef2d459a45
--- /dev/null
+++ b/media-sound/mpg123/mpg123-0.59r.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.59r.ebuild,v 1.1 2000/08/15 21:24:56 achim Exp $
+
+P=mpg123-0.59r
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="media-sound"
+DESCRIPTION="Real Time mp3 player"
+SRC_URI="http://www.mpg123.de/mpg123/${A}"
+HOMEPAGE="http://www.mpg123.de/"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O2 -m486:${CFLAGS}:" Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ cd ${S}
+ make linux-i486
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin mpg123
+ doman mpg123.1
+ dodoc BENCHMARKING BUGS CHANGES COPYING JUKEBOX README* TODO
+
+
+}
+
+
diff --git a/media-sound/sox/files/digest b/media-sound/sox/files/digest
new file mode 100644
index 000000000000..900c9d4c5ca6
--- /dev/null
+++ b/media-sound/sox/files/digest
@@ -0,0 +1 @@
+MD5 704e897a71213565c3c46cc17176b247 sox-12.16.tar.gz
diff --git a/media-sound/sox/sox-12.16.ebuild b/media-sound/sox/sox-12.16.ebuild
new file mode 100644
index 000000000000..f4b38763bb02
--- /dev/null
+++ b/media-sound/sox/sox-12.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-12.16.ebuild,v 1.1 2000/08/15 21:24:56 achim Exp $
+
+P=sox-12.16
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="media-sound"
+DESCRIPTION="The swiss army knife of sound processing programs"
+SRC_URI="http://metalab.unc.edu/pub/Linux/apps/sound/convert/${A}"
+HOMEPAGE="http://home.sprynet.com/~cgabwell/sox.html"
+
+
+src_compile() {
+
+ cd ${S}
+ ./configure --prefix=/usr --host=${CHOST} \
+ --enable-fast-ulaw --enable-fast-alaw
+ make
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin sox
+ doman sox.1
+ dodoc CHEAT README sox.txt TIPS TODO
+
+}
+
+