summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-26 12:24:34 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-26 12:24:34 +0000
commit5512b5d3cb3aa59f3353e60835c5251c978f6d11 (patch)
treeca8c5264cb8a91e11c632790e574856eba820fea /x11-misc/xdock
parentVersion bump. Bug #342729 (diff)
downloadgentoo-2-5512b5d3cb3aa59f3353e60835c5251c978f6d11.tar.gz
gentoo-2-5512b5d3cb3aa59f3353e60835c5251c978f6d11.tar.bz2
gentoo-2-5512b5d3cb3aa59f3353e60835c5251c978f6d11.zip
remove ldconfig from build system
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xdock')
-rw-r--r--x11-misc/xdock/ChangeLog9
-rw-r--r--x11-misc/xdock/files/xdock-0.2.0-ldconfig.patch8
-rw-r--r--x11-misc/xdock/xdock-0.2.0.ebuild13
3 files changed, 26 insertions, 4 deletions
diff --git a/x11-misc/xdock/ChangeLog b/x11-misc/xdock/ChangeLog
index dfd6180e81fc..c4fa3b12530e 100644
--- a/x11-misc/xdock/ChangeLog
+++ b/x11-misc/xdock/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xdock
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdock/ChangeLog,v 1.2 2008/11/24 13:13:02 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdock/ChangeLog,v 1.3 2010/10/26 12:24:34 xmw Exp $
+
+ 26 Oct 2010; Michael Weber <xmw@gentoo.org> xdock-0.2.0.ebuild,
+ +files/xdock-0.2.0-ldconfig.patch:
+ Remove ldconfig from build system, thanks to Oleg Popov
+ <dev-random@mail.ru> on bug #342519.
24 Nov 2008; <ssuominen@gentoo.org> metadata.xml:
Remove my old e-mail drac at gentoo.org from metadata.xml and leave this
diff --git a/x11-misc/xdock/files/xdock-0.2.0-ldconfig.patch b/x11-misc/xdock/files/xdock-0.2.0-ldconfig.patch
new file mode 100644
index 000000000000..409c6935d63d
--- /dev/null
+++ b/x11-misc/xdock/files/xdock-0.2.0-ldconfig.patch
@@ -0,0 +1,8 @@
+--- xdock-0.2.0/src/lib/Makefile.am
++++ xdock-0.2.0/src/lib/Makefile.am
+@@ -8,5 +8,3 @@
+
+ include_HEADERS = xdock.h
+
+-install-exec-hook:
+- ldconfig
diff --git a/x11-misc/xdock/xdock-0.2.0.ebuild b/x11-misc/xdock/xdock-0.2.0.ebuild
index 94b974d7fe67..817c20aa845e 100644
--- a/x11-misc/xdock/xdock-0.2.0.ebuild
+++ b/x11-misc/xdock/xdock-0.2.0.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdock/xdock-0.2.0.ebuild,v 1.1 2008/01/13 10:12:02 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdock/xdock-0.2.0.ebuild,v 1.2 2010/10/26 12:24:34 xmw Exp $
+
+EAPI=2
+
+inherit autotools eutils
DESCRIPTION="emulates Window Maker docks (runs in any window manager)"
HOMEPAGE="http://xdock.sourceforge.net"
@@ -15,6 +19,11 @@ RDEPEND="x11-libs/libX11
media-libs/imlib"
DEPEND="${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldconfig.patch
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc API AUTHORS ChangeLog README TODO