summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xdock/xdock-0.2.0.ebuild')
-rw-r--r--x11-misc/xdock/xdock-0.2.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/x11-misc/xdock/xdock-0.2.0.ebuild b/x11-misc/xdock/xdock-0.2.0.ebuild
index 94b974d7fe67..817c20aa845e 100644
--- a/x11-misc/xdock/xdock-0.2.0.ebuild
+++ b/x11-misc/xdock/xdock-0.2.0.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdock/xdock-0.2.0.ebuild,v 1.1 2008/01/13 10:12:02 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdock/xdock-0.2.0.ebuild,v 1.2 2010/10/26 12:24:34 xmw Exp $
+
+EAPI=2
+
+inherit autotools eutils
DESCRIPTION="emulates Window Maker docks (runs in any window manager)"
HOMEPAGE="http://xdock.sourceforge.net"
@@ -15,6 +19,11 @@ RDEPEND="x11-libs/libX11
media-libs/imlib"
DEPEND="${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldconfig.patch
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc API AUTHORS ChangeLog README TODO