summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-19 12:03:39 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-19 12:03:39 +0000
commitbc2ae9caa58c43eb3658d9c252755c632a1aed71 (patch)
treef811046db1437f50d519987330e07336371736fa /sci-biology/tophat/tophat-2.0.2.ebuild
parentBuild with gcc-4.7 Bug #425286 (diff)
downloadgentoo-2-bc2ae9caa58c43eb3658d9c252755c632a1aed71.tar.gz
gentoo-2-bc2ae9caa58c43eb3658d9c252755c632a1aed71.tar.bz2
gentoo-2-bc2ae9caa58c43eb3658d9c252755c632a1aed71.zip
sci-biology/tophat: Version BUmp; do parallel builds; handle debug build
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/tophat/tophat-2.0.2.ebuild')
-rw-r--r--sci-biology/tophat/tophat-2.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-biology/tophat/tophat-2.0.2.ebuild b/sci-biology/tophat/tophat-2.0.2.ebuild
new file mode 100644
index 000000000000..b84186581aca
--- /dev/null
+++ b/sci-biology/tophat/tophat-2.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-2.0.2.ebuild,v 1.1 2012/07/19 12:03:38 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
+HOMEPAGE="http://tophat.cbcb.umd.edu/"
+SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bam debug"
+
+DEPEND="
+ dev-libs/boost
+ bam? ( sci-biology/samtools )"
+RDEPEND="${DEPEND}
+ sci-biology/bowtie"
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+src_configure() {
+ local myeconfargs=( $(use_enable debug) )
+ autotools-utils_src_configure
+}