summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-19 12:03:39 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-19 12:03:39 +0000
commitbc2ae9caa58c43eb3658d9c252755c632a1aed71 (patch)
treef811046db1437f50d519987330e07336371736fa /sci-biology/tophat
parentBuild with gcc-4.7 Bug #425286 (diff)
downloadgentoo-2-bc2ae9caa58c43eb3658d9c252755c632a1aed71.tar.gz
gentoo-2-bc2ae9caa58c43eb3658d9c252755c632a1aed71.tar.bz2
gentoo-2-bc2ae9caa58c43eb3658d9c252755c632a1aed71.zip
sci-biology/tophat: Version BUmp; do parallel builds; handle debug build
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/tophat')
-rw-r--r--sci-biology/tophat/ChangeLog8
-rw-r--r--sci-biology/tophat/files/tophat-2.0.2-flags.patch124
-rw-r--r--sci-biology/tophat/metadata.xml2
-rw-r--r--sci-biology/tophat/tophat-2.0.0.ebuild23
-rw-r--r--sci-biology/tophat/tophat-2.0.2.ebuild31
5 files changed, 174 insertions, 14 deletions
diff --git a/sci-biology/tophat/ChangeLog b/sci-biology/tophat/ChangeLog
index 93e0142cbc45..f8f1be7bbe04 100644
--- a/sci-biology/tophat/ChangeLog
+++ b/sci-biology/tophat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/tophat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.8 2012/04/25 16:39:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.9 2012/07/19 12:03:38 jlec Exp $
+
+*tophat-2.0.2 (19 Jul 2012)
+
+ 19 Jul 2012; Justin Lecher <jlec@gentoo.org> tophat-2.0.0.ebuild,
+ +tophat-2.0.2.ebuild, +files/tophat-2.0.2-flags.patch, metadata.xml:
+ Version BUmp; do parallel builds; handle debug build
25 Apr 2012; Justin Lecher <jlec@gentoo.org> tophat-1.0.12.ebuild,
tophat-1.4.1.ebuild, tophat-2.0.0.ebuild:
diff --git a/sci-biology/tophat/files/tophat-2.0.2-flags.patch b/sci-biology/tophat/files/tophat-2.0.2-flags.patch
new file mode 100644
index 000000000000..ac1ca62da254
--- /dev/null
+++ b/sci-biology/tophat/files/tophat-2.0.2-flags.patch
@@ -0,0 +1,124 @@
+ configure.ac | 6 +++---
+ src/Makefile.am | 30 +++++++++++++++---------------
+ 2 files changed, 18 insertions(+), 18 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 314a78e..f6933e6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,7 +68,8 @@ AC_CANONICAL_HOST
+ # set CFLAGS and CXXFLAGS
+ #user_CFLAGS="${CXXFLAGS}"
+ user_CFLAGS=${CFLAGS}
+-generic_CFLAGS="-Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized"
++#generic_CFLAGS="-Wall -Wno-strict-aliasing -Wuninitialized"
++generic_CFLAGS=""
+ ext_CFLAGS=""
+ debug_CFLAGS=""
+ AC_ARG_ENABLE(intel64, [ --enable-intel64 optimize for Intel64 CPU such as Xeon and Core2],
+@@ -84,7 +85,7 @@ AC_ARG_ENABLE([optim],
+ [if test "x$enable_optim" = xyes; then enable_optim=3; fi],
+ [enable_optim=3])
+
+-AS_IF([test "x$enable_optim" != xno], [ext_CFLAGS="$ext_CFLAGS -O$enable_optim"])
++#AS_IF([test "x$enable_optim" != xno], [ext_CFLAGS="$ext_CFLAGS -O$enable_optim"])
+ AS_IF([test "x$enable_debug" = xyes],
+ [debug_CFLAGS="-DDEBUG"],
+ [debug_CFLAGS="-DNDEBUG"])
+@@ -92,7 +93,6 @@ AS_IF([test "x$enable_debug" = xyes],
+ CFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CFLAGS} ${debug_CFLAGS}"
+ CXXFLAGS="$CFLAGS"
+ CXXFLAGS="$CXXFLAGS $BOOST_CPPFLAGS $BAM_CPPFLAGS -I./SeqAn-1.3"
+-LDFLAGS="$ext_LDFLAGS"
+
+ AM_INIT_AUTOMAKE([-Wall foreign tar-pax foreign])
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index aa17841..42f9c0c 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -2,7 +2,7 @@
+
+ #SUBDIRS = samtools
+
+-#AM_CXXFLAGS = -I$(top_srcdir)/src/SeqAn-1.3
++AM_CXXFLAGS = -I$(top_srcdir)/src/SeqAn-1.3
+
+ # Generated with
+ # find SeqAn-1.3 -type f -print | grep -v ".svn" | sed 's/$/ \\/g'
+@@ -550,7 +550,7 @@ CLEANFILES = \
+ tophat2
+
+ tophat2: tophat2.in
+- sed -e 's|__PREFIX__|$(prefix)|' tophat2.in > tophat2
++ sed -e 's|__PREFIX__|$(prefix)|' $(top_srcdir)/src/tophat2.in > tophat2
+
+ #SUFFIXES = .py
+ #.py:
+@@ -621,53 +621,53 @@ libgc_a_SOURCES = \
+ #-- program sources
+
+ prep_reads_SOURCES = prep_reads.cpp
+-prep_reads_LDADD = $(top_builddir)/src/libtophat.a $(BAM_LIB)
++prep_reads_LDADD = libtophat.a $(BAM_LIB)
+ prep_reads_LDFLAGS = $(BAM_LDFLAGS)
+
+ segment_juncs_SOURCES = segment_juncs.cpp
+-segment_juncs_LDADD = $(top_builddir)/src/libtophat.a $(BOOST_THREAD_LIB) $(BAM_LIB)
++segment_juncs_LDADD = libtophat.a $(BOOST_THREAD_LIB) $(BAM_LIB)
+ segment_juncs_LDFLAGS = $(BOOST_LDFLAGS) $(BAM_LDFLAGS)
+
+ long_spanning_reads_SOURCES = long_spanning_reads.cpp
+-long_spanning_reads_LDADD = $(top_builddir)/src/libtophat.a $(BOOST_THREAD_LIB) $(BAM_LIB)
++long_spanning_reads_LDADD = libtophat.a $(BOOST_THREAD_LIB) $(BAM_LIB)
+ long_spanning_reads_LDFLAGS = $(BOOST_LDFLAGS) $(BAM_LDFLAGS)
+
+ gtf_juncs_SOURCES = gtf_juncs.cpp
+-gtf_juncs_LDADD = $(top_builddir)/src/libtophat.a libgc.a $(BAM_LIB)
++gtf_juncs_LDADD = libtophat.a libgc.a $(BAM_LIB)
+ gtf_juncs_LDFLAGS = $(BAM_LDFLAGS)
+
+ juncs_db_SOURCES = juncs_db.cpp
+-juncs_db_LDADD = $(top_builddir)/src/libtophat.a $(BAM_LIB)
++juncs_db_LDADD = libtophat.a $(BAM_LIB)
+ juncs_db_LDFLAGS = $(BAM_LDFLAGS)
+
+ tophat_reports_SOURCES = tophat_reports.cpp
+-tophat_reports_LDADD = $(top_builddir)/src/libtophat.a $(BOOST_THREAD_LIB) $(BAM_LIB)
++tophat_reports_LDADD = libtophat.a $(BOOST_THREAD_LIB) $(BAM_LIB)
+ tophat_reports_LDFLAGS = $(BOOST_LDFLAGS) $(BAM_LDFLAGS)
+
+ fix_map_ordering_SOURCES = fix_map_ordering.cpp
+-fix_map_ordering_LDADD = $(top_builddir)/src/libtophat.a $(BAM_LIB)
++fix_map_ordering_LDADD = libtophat.a $(BAM_LIB)
+ fix_map_ordering_LDFLAGS = $(BAM_LDFLAGS)
+
+ bam2fastx_SOURCES = bam2fastx.cpp
+-bam2fastx_LDADD = $(top_builddir)/src/libgc.a $(BAM_LIB)
++bam2fastx_LDADD = libgc.a $(BAM_LIB)
+ bam2fastx_LDFLAGS = $(BAM_LDFLAGS)
+
+ bam_merge_SOURCES = bam_merge.cpp
+-bam_merge_LDADD = $(top_builddir)/src/libtophat.a $(top_builddir)/src/libgc.a $(BAM_LIB)
++bam_merge_LDADD = libtophat.a libgc.a $(BAM_LIB)
+ bam_merge_LDFLAGS = $(BAM_LDFLAGS)
+
+ closure_juncs_SOURCES = closures.cpp
+-closure_juncs_LDADD = $(top_builddir)/src/libtophat.a $(BAM_LIB)
++closure_juncs_LDADD = libtophat.a $(BAM_LIB)
+ closure_juncs_LDFLAGS = $(BAM_LDFLAGS)
+
+ sam_juncs_SOURCES = sam_juncs.cpp
+-sam_juncs_LDADD = $(top_builddir)/src/libtophat.a $(BAM_LIB)
++sam_juncs_LDADD = libtophat.a $(BAM_LIB)
+ sam_juncs_LDFLAGS = $(BAM_LDFLAGS)
+
+ map2gtf_SOURCES = map2gtf.cpp
+-map2gtf_LDADD = $(top_builddir)/src/libtophat.a libgc.a $(BAM_LIB)
++map2gtf_LDADD = libtophat.a libgc.a $(BAM_LIB)
+ map2gtf_LDFLAGS = $(BAM_LDFLAGS)
+
+ gtf_to_fasta_SOURCES = GTFToFasta.cpp FastaTools.cpp
+-gtf_to_fasta_LDADD = $(top_builddir)/src/libtophat.a libgc.a $(BAM_LIB)
++gtf_to_fasta_LDADD = libtophat.a libgc.a $(BAM_LIB)
+ gtf_to_fasta_LDFLAGS = $(BAM_LDFLAGS)
diff --git a/sci-biology/tophat/metadata.xml b/sci-biology/tophat/metadata.xml
index 6631e9455420..8dc2f2067543 100644
--- a/sci-biology/tophat/metadata.xml
+++ b/sci-biology/tophat/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<herd>sci-biology</herd>
<use>
- <flag name='bam'>Compile support for the BAM format</flag>
+ <flag name="bam">Compile support for the BAM format</flag>
</use>
</pkgmetadata>
diff --git a/sci-biology/tophat/tophat-2.0.0.ebuild b/sci-biology/tophat/tophat-2.0.0.ebuild
index b652da021077..de02f86fb3f4 100644
--- a/sci-biology/tophat/tophat-2.0.0.ebuild
+++ b/sci-biology/tophat/tophat-2.0.0.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-2.0.0.ebuild,v 1.2 2012/04/25 16:39:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-2.0.0.ebuild,v 1.3 2012/07/19 12:03:38 jlec Exp $
EAPI=4
-inherit flag-o-matic autotools
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
HOMEPAGE="http://tophat.cbcb.umd.edu/"
@@ -12,21 +14,18 @@ SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
-IUSE="+bam"
KEYWORDS="~amd64 ~x86"
+IUSE="+bam debug"
-DEPEND="bam? ( sci-biology/samtools )"
+DEPEND="
+ dev-libs/boost
+ bam? ( sci-biology/samtools )"
RDEPEND="${DEPEND}
sci-biology/bowtie"
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_prepare() {
- filter-ldflags -Wl,--as-needed
- eautoreconf
-}
+PATCHES=( "${FILESDIR}"/${PN}-2.0.2-flags.patch )
src_configure() {
- econf \
- $(use_with bam)
+ local myeconfargs=( $(use_enable debug) )
+ autotools-utils_src_configure
}
diff --git a/sci-biology/tophat/tophat-2.0.2.ebuild b/sci-biology/tophat/tophat-2.0.2.ebuild
new file mode 100644
index 000000000000..b84186581aca
--- /dev/null
+++ b/sci-biology/tophat/tophat-2.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-2.0.2.ebuild,v 1.1 2012/07/19 12:03:38 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
+HOMEPAGE="http://tophat.cbcb.umd.edu/"
+SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bam debug"
+
+DEPEND="
+ dev-libs/boost
+ bam? ( sci-biology/samtools )"
+RDEPEND="${DEPEND}
+ sci-biology/bowtie"
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+src_configure() {
+ local myeconfargs=( $(use_enable debug) )
+ autotools-utils_src_configure
+}