summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-01-14 15:07:09 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-01-14 15:07:09 +0000
commitf54f0377d399bf4e79bc29059999aa32946efed0 (patch)
tree9adaf1eefa5c3a38d6d8ede281f39bd9cc84cc9e /net-wireless/wpa_supplicant
parentTransfer Prefix keywords (diff)
downloadgentoo-2-f54f0377d399bf4e79bc29059999aa32946efed0.tar.gz
gentoo-2-f54f0377d399bf4e79bc29059999aa32946efed0.tar.bz2
gentoo-2-f54f0377d399bf4e79bc29059999aa32946efed0.zip
Adding support for FAST-EAP, fixing bug #300215.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'net-wireless/wpa_supplicant')
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog14
-rw-r--r--net-wireless/wpa_supplicant/metadata.xml1
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild14
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.7.0.ebuild14
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild18
5 files changed, 48 insertions, 13 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index a8430351724e..6d0329977900 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-wireless/wpa_supplicant
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.126 2009/12/14 12:50:27 gurligebis Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.127 2010/01/14 15:07:09 gurligebis Exp $
+
+ 14 Jan 2010; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
+ wpa_supplicant-0.6.9.ebuild, wpa_supplicant-0.7.0.ebuild,
+ wpa_supplicant-9999.ebuild, metadata.xml:
+ Adding support for FAST-EAP, fixing bug #300215
+
+ 14 Jan 2010; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
+ wpa_supplicant-9999.ebuild,
+ +files/wpa_supplicant-9999-dbus_path_fix.patch:
+ Fixing bugs #300633 and #300305
*wpa_supplicant-0.7.0 (14 Dec 2009)
diff --git a/net-wireless/wpa_supplicant/metadata.xml b/net-wireless/wpa_supplicant/metadata.xml
index 8a9e4de0af3f..efaff3713119 100644
--- a/net-wireless/wpa_supplicant/metadata.xml
+++ b/net-wireless/wpa_supplicant/metadata.xml
@@ -8,6 +8,7 @@
<herd>mobile</herd>
<use>
<flag name='eap-sim'>Add support for EAP-SIM authentication algorithm</flag>
+ <flag name='fasteap'>Add support for FAST-EAP authentication algorithm</flag>
<flag name='madwifi'>Add support for madwifi (Atheros chipset)</flag>
<flag name='ps3'>Add support for ps3 hypervisor driven gelic wifi</flag>
<flag name='wps'>Add support for Wi-Fi Protected Setup</flag>
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild
index 79b2403f454b..8aa889c99359 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild,v 1.8 2009/11/21 12:03:21 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild,v 1.9 2010/01/14 15:07:09 gurligebis Exp $
EAPI="2"
@@ -13,7 +13,7 @@ LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
-IUSE="dbus debug gnutls eap-sim madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
+IUSE="dbus debug gnutls eap-sim fasteap madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
DEPEND="dev-libs/libnl
dbus? ( sys-apps/dbus )
@@ -37,6 +37,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${P}/${PN}"
pkg_setup() {
+ if use fasteap && (use gnutls || use ssl) ; then
+ die "If you use fasteap, you must build with wpa_supplicant's internal TLS implementation. That is, both 'gnutls' and 'ssl' USE flags must be disabled"
+ fi
+
if use gnutls && use ssl ; then
einfo "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
fi
@@ -110,6 +114,10 @@ src_configure() {
echo "CONFIG_PCSC=y" >> .config
fi
+ if use fasteap ; then
+ echo "CONFIG_EAP_FAST=y" >> .config
+ fi
+
if use readline ; then
# readline/history support for wpa_cli
echo "CONFIG_READLINE=y" >> .config
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.7.0.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.7.0.ebuild
index e9f844bf7499..80efa9aa077e 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.7.0.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.7.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.7.0.ebuild,v 1.1 2009/12/14 12:50:27 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.7.0.ebuild,v 1.2 2010/01/14 15:07:09 gurligebis Exp $
EAPI="2"
@@ -13,7 +13,7 @@ LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="dbus debug gnutls eap-sim madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
+IUSE="dbus debug gnutls eap-sim fasteap madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
DEPEND="dev-libs/libnl
dbus? ( sys-apps/dbus )
@@ -37,6 +37,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${P}/${PN}"
pkg_setup() {
+ if use fasteap && (use gnutls || use ssl) ; then
+ die "If you use fasteap, you must build with wpa_supplicant's internal TLS implementation. That is, both 'gnutls' and 'ssl' USE flags must be disabled"
+ fi
+
if use gnutls && use ssl ; then
einfo "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
fi
@@ -110,6 +114,10 @@ src_configure() {
echo "CONFIG_PCSC=y" >> .config
fi
+ if use fasteap ; then
+ echo "CONFIG_EAP_FAST=y" >> .config
+ fi
+
if use readline ; then
# readline/history support for wpa_cli
echo "CONFIG_READLINE=y" >> .config
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index 9bcba97f3d62..0e9deb9418a0 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild,v 1.2 2009/05/22 08:11:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild,v 1.3 2010/01/14 15:07:09 gurligebis Exp $
EAPI="2"
inherit eutils toolchain-funcs qt3 qt4
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="http://w1.fi/hostap.git"
+ EGIT_REPO_URI="git://w1.fi/srv/git/hostap.git"
inherit git
SRC_URI=""
S="${WORKDIR}/${P}/${PN}/${PN}"
@@ -23,7 +23,7 @@ LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
KEYWORDS="-*"
-IUSE="dbus debug gnutls eap-sim madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
+IUSE="dbus debug gnutls eap-sim fasteap madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
DEPEND="dev-libs/libnl
dbus? ( sys-apps/dbus )
@@ -58,6 +58,10 @@ src_unpack() {
}
pkg_setup() {
+ if use fasteap && (use gnutls || use ssl) ; then
+ die "If you use fasteap, you must build with wpa_supplicant's internal TLS implementation. That is, both 'gnutls' and 'ssl' USE flags must be disabled"
+ fi
+
if use gnutls && use ssl ; then
einfo "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
fi
@@ -88,7 +92,7 @@ src_prepare() {
-e "s:/usr/lib/pkcs11:/usr/$(get_libdir):" \
wpa_supplicant.conf || die
- epatch "${FILESDIR}"/dbus_path_fix.patch
+ epatch "${FILESDIR}"/${P}-dbus_path_fix.patch
}
src_configure() {
@@ -134,6 +138,10 @@ src_configure() {
echo "CONFIG_PCSC=y" >> .config
fi
+ if use fasteap ; then
+ echo "CONFIG_EAP_FAST=y" >> .config
+ fi
+
if use readline ; then
# readline/history support for wpa_cli
echo "CONFIG_READLINE=y" >> .config