summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild')
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild
index 79b2403f454b..8aa889c99359 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild,v 1.8 2009/11/21 12:03:21 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.6.9.ebuild,v 1.9 2010/01/14 15:07:09 gurligebis Exp $
EAPI="2"
@@ -13,7 +13,7 @@ LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
-IUSE="dbus debug gnutls eap-sim madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
+IUSE="dbus debug gnutls eap-sim fasteap madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
DEPEND="dev-libs/libnl
dbus? ( sys-apps/dbus )
@@ -37,6 +37,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${P}/${PN}"
pkg_setup() {
+ if use fasteap && (use gnutls || use ssl) ; then
+ die "If you use fasteap, you must build with wpa_supplicant's internal TLS implementation. That is, both 'gnutls' and 'ssl' USE flags must be disabled"
+ fi
+
if use gnutls && use ssl ; then
einfo "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
fi
@@ -110,6 +114,10 @@ src_configure() {
echo "CONFIG_PCSC=y" >> .config
fi
+ if use fasteap ; then
+ echo "CONFIG_EAP_FAST=y" >> .config
+ fi
+
if use readline ; then
# readline/history support for wpa_cli
echo "CONFIG_READLINE=y" >> .config