summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-25 01:46:02 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-25 01:46:02 +0000
commit84f7514a065457ccfe62829481e16f2691d40a95 (patch)
treea46510e6b1debde5a8e8e281643fa599d7a3864e /net-p2p
parentBump (diff)
downloadgentoo-2-84f7514a065457ccfe62829481e16f2691d40a95.tar.gz
gentoo-2-84f7514a065457ccfe62829481e16f2691d40a95.tar.bz2
gentoo-2-84f7514a065457ccfe62829481e16f2691d40a95.zip
Updates to support BIP16 required by April 1, 2012
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-qt/ChangeLog16
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild122
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.5-r1.ebuild122
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.6_rc1.ebuild (renamed from net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4.ebuild)18
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.5.1.ebuild4
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.5.3-r2.ebuild122
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.5.3.ebuild4
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.5.4_rc1.ebuild (renamed from net-p2p/bitcoin-qt/bitcoin-qt-0.5.3-r1.ebuild)16
-rw-r--r--net-p2p/bitcoin-qt/files/0.5.0.5+bip16-eligius_sendfee.patch169
-rw-r--r--net-p2p/bitcoin-qt/metadata.xml5
10 files changed, 582 insertions, 16 deletions
diff --git a/net-p2p/bitcoin-qt/ChangeLog b/net-p2p/bitcoin-qt/ChangeLog
index 43b5d7e99ce7..217bafcc87d3 100644
--- a/net-p2p/bitcoin-qt/ChangeLog
+++ b/net-p2p/bitcoin-qt/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for net-p2p/bitcoin-qt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.17 2012/03/18 20:05:58 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/ChangeLog,v 1.18 2012/03/25 01:46:02 blueness Exp $
+
+*bitcoin-qt-0.5.4_rc1 (25 Mar 2012)
+*bitcoin-qt-0.5.3-r2 (25 Mar 2012)
+*bitcoin-qt-0.5.0.6_rc1 (25 Mar 2012)
+*bitcoin-qt-0.5.0.5-r1 (25 Mar 2012)
+*bitcoin-qt-0.5.0.4-r1 (25 Mar 2012)
+
+ 25 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
+ +files/0.5.0.5+bip16-eligius_sendfee.patch, -bitcoin-qt-0.5.0.4.ebuild,
+ +bitcoin-qt-0.5.0.4-r1.ebuild, +bitcoin-qt-0.5.0.5-r1.ebuild,
+ +bitcoin-qt-0.5.0.6_rc1.ebuild, bitcoin-qt-0.5.1.ebuild,
+ bitcoin-qt-0.5.3.ebuild, -bitcoin-qt-0.5.3-r1.ebuild,
+ +bitcoin-qt-0.5.3-r2.ebuild, +bitcoin-qt-0.5.4_rc1.ebuild, metadata.xml:
+ Updates to support BIP16 required by April 1, 2012
18 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
bitcoin-qt-0.6.0_rc4.ebuild:
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild
new file mode 100644
index 000000000000..760a0e41ebae
--- /dev/null
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild,v 1.1 2012/03/25 01:46:02 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+LANGS="da de en es es_CL nb nl ru zh_TW"
+inherit db-use eutils qt4-r2 versionator
+
+DESCRIPTION="An end-user Qt4 GUI for the Bitcoin crypto-currency"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-validating-BIP16-pay-to-script-h.patch.xz
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.5.0.6rc1-eligius_sendfee.patch.xz )
+ )
+"
+
+LICENSE="MIT ISC CCPL-Attribution-3.0 GPL-3 md2k7-asyouwish LGPL-2.1 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="$IUSE +bip16 dbus +eligius ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ x11-libs/qt-gui
+ dbus? (
+ x11-libs/qt-dbus
+ )
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+DOCS="doc/README"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+src_prepare() {
+ cd src || die
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-validating-BIP16-pay-to-script-h.patch"
+ if use bip16; then
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/0.5.0.5+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.5.0.6rc1-eligius_sendfee.patch"
+ fi
+
+ local filt= yeslang= nolang=
+
+ for lan in $LANGS; do
+ if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
+ ewarn "Language '$lan' no longer supported. Ebuild needs update."
+ fi
+ done
+
+ for ts in $(ls qt/locale/*.ts)
+ do
+ x="${ts/*bitcoin_/}"
+ x="${x/.ts/}"
+ if ! use "linguas_$x"; then
+ nolang="$nolang $x"
+ rm "$ts"
+ filt="$filt\\|$x"
+ else
+ yeslang="$yeslang $x"
+ fi
+ done
+ filt="bitcoin_\\(${filt:2}\\)\\.qm"
+ sed "/${filt}/d" -i 'qt/bitcoin.qrc'
+ einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
+}
+
+src_configure() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER
+
+ use dbus && OPTS+=("USE_DBUS=1")
+ use ssl && OPTS+=("DEFINES+=USE_SSL")
+ if use upnp; then
+ OPTS+=("USE_UPNP=1")
+ else
+ OPTS+=("USE_UPNP=-")
+ fi
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ OPTS+=("BOOST_INCLUDE_PATH=/usr/include/boost-${BOOST_VER}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ eqmake4 "${PN}.pro" "${OPTS[@]}"
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ cd src || die
+ emake -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${PN}
+ insinto /usr/share/pixmaps
+ newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
+ make_desktop_entry ${PN} "Bitcoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Network;P2P"
+}
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.5-r1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.5-r1.ebuild
new file mode 100644
index 000000000000..5fc744d3b774
--- /dev/null
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.5-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.5-r1.ebuild,v 1.1 2012/03/25 01:46:02 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+LANGS="da de en es es_CL nb nl ru zh_TW"
+inherit db-use eutils qt4-r2 versionator
+
+DESCRIPTION="An end-user Qt4 GUI for the Bitcoin crypto-currency"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ http://luke.dashjr.org/programs/bitcoin/files/bip16/${PV}-Minimal-support-for-validating-BIP16-pay-to-script-h.patch.xz
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/${PV}-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.5.0.6rc1-eligius_sendfee.patch.xz )
+ )
+"
+
+LICENSE="MIT ISC CCPL-Attribution-3.0 GPL-3 md2k7-asyouwish LGPL-2.1 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="$IUSE +bip16 dbus +eligius ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ x11-libs/qt-gui
+ dbus? (
+ x11-libs/qt-dbus
+ )
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+DOCS="doc/README"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+src_prepare() {
+ cd src || die
+ epatch "${WORKDIR}/${PV}-Minimal-support-for-validating-BIP16-pay-to-script-h.patch"
+ if use bip16; then
+ epatch "${WORKDIR}/${PV}-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/${PV}+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.5.0.6rc1-eligius_sendfee.patch"
+ fi
+
+ local filt= yeslang= nolang=
+
+ for lan in $LANGS; do
+ if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
+ ewarn "Language '$lan' no longer supported. Ebuild needs update."
+ fi
+ done
+
+ for ts in $(ls qt/locale/*.ts)
+ do
+ x="${ts/*bitcoin_/}"
+ x="${x/.ts/}"
+ if ! use "linguas_$x"; then
+ nolang="$nolang $x"
+ rm "$ts"
+ filt="$filt\\|$x"
+ else
+ yeslang="$yeslang $x"
+ fi
+ done
+ filt="bitcoin_\\(${filt:2}\\)\\.qm"
+ sed "/${filt}/d" -i 'qt/bitcoin.qrc'
+ einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
+}
+
+src_configure() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER
+
+ use dbus && OPTS+=("USE_DBUS=1")
+ use ssl && OPTS+=("DEFINES+=USE_SSL")
+ if use upnp; then
+ OPTS+=("USE_UPNP=1")
+ else
+ OPTS+=("USE_UPNP=-")
+ fi
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ OPTS+=("BOOST_INCLUDE_PATH=/usr/include/boost-${BOOST_VER}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ eqmake4 "${PN}.pro" "${OPTS[@]}"
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ cd src || die
+ emake -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${PN}
+ insinto /usr/share/pixmaps
+ newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
+ make_desktop_entry ${PN} "Bitcoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Network;P2P"
+}
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.6_rc1.ebuild
index a8512a74cc25..041789755a44 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.6_rc1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4.ebuild,v 1.2 2012/03/18 00:19:29 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.6_rc1.ebuild,v 1.1 2012/03/25 01:46:02 blueness Exp $
-EAPI=4
+EAPI="4"
DB_VER="4.8"
@@ -12,13 +12,16 @@ inherit db-use eutils qt4-r2 versionator
DESCRIPTION="An end-user Qt4 GUI for the Bitcoin crypto-currency"
HOMEPAGE="http://bitcoin.org/"
SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.5.0.6rc1-eligius_sendfee.patch.xz )
+ )
"
LICENSE="MIT ISC CCPL-Attribution-3.0 GPL-3 md2k7-asyouwish LGPL-2.1 public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="$IUSE dbus +eligius ssl upnp"
+IUSE="$IUSE +bip16 dbus +eligius ssl upnp"
RDEPEND="
>=dev-libs/boost-1.41.0
@@ -42,7 +45,12 @@ S="${WORKDIR}/bitcoin-bitcoind-stable"
src_prepare() {
cd src || die
- use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
+ if use bip16; then
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/0.5.0.5+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.5.0.6rc1-eligius_sendfee.patch"
+ fi
local filt= yeslang= nolang=
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.1.ebuild
index e6ce132e2de5..6c85eba3276b 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.1.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.1.ebuild,v 1.4 2012/03/09 09:31:15 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.1.ebuild,v 1.5 2012/03/25 01:46:02 blueness Exp $
-EAPI=4
+EAPI="4"
DB_VER="4.8"
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3-r2.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3-r2.ebuild
new file mode 100644
index 000000000000..41bccb4b0d7c
--- /dev/null
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3-r2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3-r2.ebuild,v 1.1 2012/03/25 01:46:02 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+LANGS="da de en es es_CL hu it nb nl pt_BR ru uk zh_CN zh_TW"
+inherit db-use eutils qt4-r2 versionator
+
+DESCRIPTION="An end-user Qt4 GUI for the Bitcoin crypto-currency"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-validating-BIP16-pay-to-script-h.patch.xz
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.5.0.6rc1-eligius_sendfee.patch.xz )
+ )
+"
+
+LICENSE="MIT ISC GPL-3 md2k7-asyouwish LGPL-2.1 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="$IUSE +bip16 dbus +eligius ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ x11-libs/qt-gui
+ dbus? (
+ x11-libs/qt-dbus
+ )
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+DOCS="doc/README"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+src_prepare() {
+ cd src || die
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-validating-BIP16-pay-to-script-h.patch"
+ if use bip16; then
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/0.5.0.5+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.5.0.6rc1-eligius_sendfee.patch"
+ fi
+
+ local filt= yeslang= nolang=
+
+ for lan in $LANGS; do
+ if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
+ ewarn "Language '$lan' no longer supported. Ebuild needs update."
+ fi
+ done
+
+ for ts in $(ls qt/locale/*.ts)
+ do
+ x="${ts/*bitcoin_/}"
+ x="${x/.ts/}"
+ if ! use "linguas_$x"; then
+ nolang="$nolang $x"
+ rm "$ts"
+ filt="$filt\\|$x"
+ else
+ yeslang="$yeslang $x"
+ fi
+ done
+ filt="bitcoin_\\(${filt:2}\\)\\.qm"
+ sed "/${filt}/d" -i 'qt/bitcoin.qrc'
+ einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
+}
+
+src_configure() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER
+
+ use dbus && OPTS+=("USE_DBUS=1")
+ use ssl && OPTS+=("DEFINES+=USE_SSL")
+ if use upnp; then
+ OPTS+=("USE_UPNP=1")
+ else
+ OPTS+=("USE_UPNP=-")
+ fi
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ OPTS+=("BOOST_INCLUDE_PATH=/usr/include/boost-${BOOST_VER}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ eqmake4 "${PN}.pro" "${OPTS[@]}"
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ cd src || die
+ emake -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${PN}
+ insinto /usr/share/pixmaps
+ newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
+ make_desktop_entry ${PN} "Bitcoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Network;P2P"
+}
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3.ebuild
index 3450f682ca56..4adae44e173a 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3.ebuild,v 1.2 2012/03/16 14:10:25 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3.ebuild,v 1.3 2012/03/25 01:46:02 blueness Exp $
-EAPI=4
+EAPI="4"
DB_VER="4.8"
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3-r1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.4_rc1.ebuild
index a2f4fb5f78fd..a84f392c413b 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3-r1.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.4_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.3-r1.ebuild,v 1.1 2012/03/18 00:13:59 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.4_rc1.ebuild,v 1.1 2012/03/25 01:46:02 blueness Exp $
EAPI="4"
@@ -12,13 +12,16 @@ inherit db-use eutils qt4-r2 versionator
DESCRIPTION="An end-user Qt4 GUI for the Bitcoin crypto-currency"
HOMEPAGE="http://bitcoin.org/"
SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
- eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.5.0.6rc1-eligius_sendfee.patch.xz )
+ )
"
LICENSE="MIT ISC GPL-3 md2k7-asyouwish LGPL-2.1 public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="$IUSE dbus +eligius ssl upnp"
+IUSE="$IUSE +bip16 dbus +eligius ssl upnp"
RDEPEND="
>=dev-libs/boost-1.41.0
@@ -42,7 +45,12 @@ S="${WORKDIR}/bitcoin-bitcoind-stable"
src_prepare() {
cd src || die
- use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
+ if use bip16; then
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/0.5.0.5+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.5.0.6rc1-eligius_sendfee.patch"
+ fi
local filt= yeslang= nolang=
diff --git a/net-p2p/bitcoin-qt/files/0.5.0.5+bip16-eligius_sendfee.patch b/net-p2p/bitcoin-qt/files/0.5.0.5+bip16-eligius_sendfee.patch
new file mode 100644
index 000000000000..ada609211509
--- /dev/null
+++ b/net-p2p/bitcoin-qt/files/0.5.0.5+bip16-eligius_sendfee.patch
@@ -0,0 +1,169 @@
+diff --git a/src/main.cpp b/src/main.cpp
+index 2e8b43d..af5e805 100644
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -428,8 +428,10 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
+ if ((int64)nLockTime > INT_MAX)
+ return error("AcceptToMemoryPool() : not accepting nLockTime beyond 2038 yet");
+
++ bool fIsMine = pwalletMain->IsMine(*this);
++
+ // Rather not work on nonstandard transactions (unless -testnet)
+- if (!fTestNet && !IsStandard())
++ if (!fTestNet && !IsStandard() && !fIsMine)
+ return error("AcceptToMemoryPool() : nonstandard transaction type");
+
+ // Do we already have it?
+@@ -494,8 +496,11 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
+ int64 nFees = GetValueIn(mapInputs)-GetValueOut();
+ unsigned int nSize = ::GetSerializeSize(*this, SER_NETWORK);
+
++ if (!fIsMine)
++ {
++
+ // Don't accept it if it can't get into a block
+- if (nFees < GetMinFee(1000, true, true))
++ if (nFees < GetMinFee(1000, true, GMF_RELAY))
+ return error("AcceptToMemoryPool() : not enough fees");
+
+ // Continuously rate-limit free transactions
+@@ -523,6 +528,8 @@ bool CTransaction::AcceptToMemoryPool(CTxDB& txdb, bool fCheckInputs, bool* pfMi
+ }
+ }
+
++ }
++
+ // Check against previous transactions
+ // This is done last to help prevent CPU exhaustion denial-of-service attacks.
+ if (!ConnectInputs(mapInputs, mapUnused, CDiskTxPos(1,1,1), pindexBest, false, false))
+@@ -3044,6 +3051,9 @@ CBlock* CreateNewBlock(CReserveKey& reservekey)
+ // Priority is sum(valuein * age) / txsize
+ dPriority /= ::GetSerializeSize(tx, SER_NETWORK);
+
++ if (pwalletMain->IsMine(tx))
++ dPriority += 100.;
++
+ if (porphan)
+ porphan->dPriority = dPriority;
+ else
+@@ -3081,7 +3091,7 @@ CBlock* CreateNewBlock(CReserveKey& reservekey)
+
+ // Transaction fee required depends on block size
+ bool fAllowFree = (nBlockSize + nTxSize < 4000 || CTransaction::AllowFree(dPriority));
+- int64 nMinFee = tx.GetMinFee(nBlockSize, fAllowFree);
++ int64 nMinFee = pwalletMain->IsMine(tx) ? 0 : tx.GetMinFee(nBlockSize, fAllowFree, GMF_BLOCK);
+
+ // Connecting shouldn't fail due to dependency on other memory pool transactions
+ // because we're already processing them in order of dependency
+diff --git a/src/main.h b/src/main.h
+index a918eb5..d3910cd 100644
+--- a/src/main.h
++++ b/src/main.h
+@@ -391,6 +391,13 @@ public:
+ typedef std::map<uint256, std::pair<CTxIndex, CTransaction> > MapPrevTx;
+
+
++enum GetMinFee_mode
++{
++ GMF_BLOCK,
++ GMF_RELAY,
++ GMF_SEND,
++};
++
+ //
+ // The basic transaction that is broadcasted on the network and contained in
+ // blocks. A transaction can contain multiple inputs and outputs.
+@@ -568,13 +575,49 @@ public:
+ return dPriority > COIN * 144 / 250;
+ }
+
+- int64 GetMinFee(unsigned int nBlockSize=1, bool fAllowFree=true, bool fForRelay=false) const
++ int64 GetMinFee(unsigned int nBlockSize=1, bool fAllowFree=true, enum GetMinFee_mode mode=GMF_BLOCK) const
+ {
+ // Base fee is either MIN_TX_FEE or MIN_RELAY_TX_FEE
+- int64 nBaseFee = fForRelay ? MIN_RELAY_TX_FEE : MIN_TX_FEE;
++ int64 nBaseFee = (mode == GMF_RELAY) ? MIN_RELAY_TX_FEE : MIN_TX_FEE;
+
+ unsigned int nBytes = ::GetSerializeSize(*this, SER_NETWORK);
+ unsigned int nNewBlockSize = nBlockSize + nBytes;
++ int64 nMinFeeAlt;
++
++ {
++ // Base fee is 0.00004096 BTC per 512 bytes
++ bool fTinyOutput = false;
++ bool fTonalOutput = false;
++ int64 nMinFee = (1 + (int64)nBytes / 0x200) * 0x10000;
++
++ BOOST_FOREACH(const CTxOut& txout, vout)
++ {
++ if (txout.nValue < 0x100)
++ {
++ fTinyOutput = true;
++ break;
++ }
++ if (0 == txout.nValue % 0x10000)
++ fTonalOutput = true;
++ }
++
++ // Charge extra for ridiculously tiny outputs
++ if (fTinyOutput)
++ nMinFee *= 0x10;
++ else
++ // Waive the fee in a tonal-sized "free tranaction area" if at least one output is TBC (and under 512 bytes) ;)
++ if (fTonalOutput && nNewBlockSize < 0x8000 && nBytes < 0x200)
++ nMinFee = 0;
++ else
++ if (fAllowFree)
++ {
++ // Give a discount to the first so many tx
++ nMinFee /= 0x10;
++ }
++
++ nMinFeeAlt = nMinFee;
++ }
++
+ int64 nMinFee = (1 + (int64)nBytes / 1000) * nBaseFee;
+
+ if (fAllowFree)
+@@ -600,6 +643,8 @@ public:
+ if (txout.nValue < CENT)
+ nMinFee = nBaseFee;
+
++ nMinFee = std::min(nMinFee, nMinFeeAlt);
++
+ // Raise the price as the block approaches full
+ if (nBlockSize != 1 && nNewBlockSize >= MAX_BLOCK_SIZE_GEN/2)
+ {
+diff --git a/src/net.cpp b/src/net.cpp
+index f37c675..5cb448d 100644
+--- a/src/net.cpp
++++ b/src/net.cpp
+@@ -1268,6 +1268,7 @@ void MapPort(bool /* unused fMapPort */)
+
+
+ static const char *strDNSSeed[] = {
++ "relay.eligius.st",
+ "bitseed.xf2.org",
+ "dnsseed.bluematt.me",
+ "seed.bitcoin.sipa.be",
+diff --git a/src/wallet.cpp b/src/wallet.cpp
+index 20c3eab..e71994b 100644
+--- a/src/wallet.cpp
++++ b/src/wallet.cpp
+@@ -959,6 +959,7 @@ bool CWallet::CreateTransaction(const vector<pair<CScript, int64> >& vecSend, CW
+ int64 nChange = nValueIn - nValue - nFeeRet;
+ // if sub-cent change is required, the fee must be raised to at least MIN_TX_FEE
+ // or until nChange becomes zero
++ // NOTE: this depends on the exact behaviour of GetMinFee
+ if (nFeeRet < MIN_TX_FEE && nChange > 0 && nChange < CENT)
+ {
+ int64 nMoveToFee = min(nChange, MIN_TX_FEE - nFeeRet);
+@@ -1012,7 +1013,7 @@ bool CWallet::CreateTransaction(const vector<pair<CScript, int64> >& vecSend, CW
+ // Check that enough fee is included
+ int64 nPayFee = nTransactionFee * (1 + (int64)nBytes / 1000);
+ bool fAllowFree = CTransaction::AllowFree(dPriority);
+- int64 nMinFee = wtxNew.GetMinFee(1, fAllowFree);
++ int64 nMinFee = wtxNew.GetMinFee(1, fAllowFree, GMF_SEND);
+ if (nFeeRet < max(nPayFee, nMinFee))
+ {
+ nFeeRet = max(nPayFee, nMinFee);
diff --git a/net-p2p/bitcoin-qt/metadata.xml b/net-p2p/bitcoin-qt/metadata.xml
index cda014bfd1c1..78dcf2a08958 100644
--- a/net-p2p/bitcoin-qt/metadata.xml
+++ b/net-p2p/bitcoin-qt/metadata.xml
@@ -10,9 +10,10 @@
<name>Luke Dashjr</name>
</maintainer>
<use>
- <flag name="1stclassmsg">Enable First Class Messaging</flag>
- <flag name="qrcode">Enable QR Code symbol support</flag>
+ <flag name='1stclassmsg'>Enable first-class Bitcoin message tools</flag>
+ <flag name='bip16'>Enable backported support for relaying and mining new BIP16 pay-to-script-hash transactions</flag>
<flag name='eligius'>Enable using lower fees accepted by Eligius</flag>
+ <flag name='qrcode'>Enable generation of QR Codes for receiving payments</flag>
<flag name='upnp'>Enable Universal Plug and Play</flag>
</use>
</pkgmetadata>