summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild')
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild122
1 files changed, 122 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild
new file mode 100644
index 000000000000..760a0e41ebae
--- /dev/null
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoin-qt/bitcoin-qt-0.5.0.4-r1.ebuild,v 1.1 2012/03/25 01:46:02 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+LANGS="da de en es es_CL nb nl ru zh_TW"
+inherit db-use eutils qt4-r2 versionator
+
+DESCRIPTION="An end-user Qt4 GUI for the Bitcoin crypto-currency"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-validating-BIP16-pay-to-script-h.patch.xz
+ bip16? ( http://luke.dashjr.org/programs/bitcoin/files/bip16/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch.xz )
+ eligius? (
+ !bip16? ( http://luke.dashjr.org/programs/bitcoin/files/eligius_sendfee/0.5.0.6rc1-eligius_sendfee.patch.xz )
+ )
+"
+
+LICENSE="MIT ISC CCPL-Attribution-3.0 GPL-3 md2k7-asyouwish LGPL-2.1 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="$IUSE +bip16 dbus +eligius ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ x11-libs/qt-gui
+ dbus? (
+ x11-libs/qt-dbus
+ )
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+DOCS="doc/README"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+src_prepare() {
+ cd src || die
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-validating-BIP16-pay-to-script-h.patch"
+ if use bip16; then
+ epatch "${WORKDIR}/0.5.0.5-Minimal-support-for-mining-BIP16-pay-to-script-hash-.patch"
+ use eligius && epatch "${FILESDIR}/0.5.0.5+bip16-eligius_sendfee.patch"
+ else
+ use eligius && epatch "${WORKDIR}/0.5.0.6rc1-eligius_sendfee.patch"
+ fi
+
+ local filt= yeslang= nolang=
+
+ for lan in $LANGS; do
+ if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
+ ewarn "Language '$lan' no longer supported. Ebuild needs update."
+ fi
+ done
+
+ for ts in $(ls qt/locale/*.ts)
+ do
+ x="${ts/*bitcoin_/}"
+ x="${x/.ts/}"
+ if ! use "linguas_$x"; then
+ nolang="$nolang $x"
+ rm "$ts"
+ filt="$filt\\|$x"
+ else
+ yeslang="$yeslang $x"
+ fi
+ done
+ filt="bitcoin_\\(${filt:2}\\)\\.qm"
+ sed "/${filt}/d" -i 'qt/bitcoin.qrc'
+ einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
+}
+
+src_configure() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER
+
+ use dbus && OPTS+=("USE_DBUS=1")
+ use ssl && OPTS+=("DEFINES+=USE_SSL")
+ if use upnp; then
+ OPTS+=("USE_UPNP=1")
+ else
+ OPTS+=("USE_UPNP=-")
+ fi
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ OPTS+=("BOOST_INCLUDE_PATH=/usr/include/boost-${BOOST_VER}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ eqmake4 "${PN}.pro" "${OPTS[@]}"
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ cd src || die
+ emake -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${PN}
+ insinto /usr/share/pixmaps
+ newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
+ make_desktop_entry ${PN} "Bitcoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Network;P2P"
+}