summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-08-21 13:28:37 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-08-21 13:28:37 +0000
commite4129fc3c5709cebbd370f10f2048e6915f9a17e (patch)
tree0ce78f12018b52ad070800accfc3845bab41f80c /net-irc/weechat/weechat-9999.ebuild
parentStable for x86, wrt bug #429134 (diff)
downloadgentoo-2-e4129fc3c5709cebbd370f10f2048e6915f9a17e.tar.gz
gentoo-2-e4129fc3c5709cebbd370f10f2048e6915f9a17e.tar.bz2
gentoo-2-e4129fc3c5709cebbd370f10f2048e6915f9a17e.zip
Sort out the dependency over py2/3 wrt bug#426330. Stabilise 0.3.8 on all archs. Remove older.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/weechat/weechat-9999.ebuild')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index ccaa6f51c9f2..ceca01ebb28a 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.19 2012/05/31 11:15:05 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.20 2012/08/21 13:28:37 scarabeus Exp $
EAPI=4
-PYTHON_DEPEND="python? *"
+PYTHON_DEPEND="python? 2" # it can use only ONE python, so stick with two for now
EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
@@ -56,7 +56,10 @@ for X in "${LANGS[@]}" ; do
done
pkg_setup() {
- use python && python_pkg_setup
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {