summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-08-21 13:28:37 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-08-21 13:28:37 +0000
commite4129fc3c5709cebbd370f10f2048e6915f9a17e (patch)
tree0ce78f12018b52ad070800accfc3845bab41f80c
parentStable for x86, wrt bug #429134 (diff)
downloadgentoo-2-e4129fc3c5709cebbd370f10f2048e6915f9a17e.tar.gz
gentoo-2-e4129fc3c5709cebbd370f10f2048e6915f9a17e.tar.bz2
gentoo-2-e4129fc3c5709cebbd370f10f2048e6915f9a17e.zip
Sort out the dependency over py2/3 wrt bug#426330. Stabilise 0.3.8 on all archs. Remove older.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
-rw-r--r--net-irc/weechat/ChangeLog8
-rw-r--r--net-irc/weechat/weechat-0.3.7.ebuild123
-rw-r--r--net-irc/weechat/weechat-0.3.8.ebuild11
-rw-r--r--net-irc/weechat/weechat-9999.ebuild9
4 files changed, 19 insertions, 132 deletions
diff --git a/net-irc/weechat/ChangeLog b/net-irc/weechat/ChangeLog
index 771aa1b2690d..dbc5e247e28c 100644
--- a/net-irc/weechat/ChangeLog
+++ b/net-irc/weechat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/weechat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.113 2012/06/07 15:22:49 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.114 2012/08/21 13:28:37 scarabeus Exp $
+
+ 21 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org> -weechat-0.3.7.ebuild,
+ weechat-0.3.8.ebuild, weechat-9999.ebuild:
+ Sort out the dependency over py2/3 wrt bug#426330. Stabilise 0.3.8 on all
+ archs. Remove older.
*weechat-0.3.8 (07 Jun 2012)
@@ -473,4 +478,3 @@
weechat-0.0.2.ebuild:
Initial version, ebuild by psk <gentoo@feeleas.org>.
Closes #29823.
-
diff --git a/net-irc/weechat/weechat-0.3.7.ebuild b/net-irc/weechat/weechat-0.3.7.ebuild
deleted file mode 100644
index 509a48f261be..000000000000
--- a/net-irc/weechat/weechat-0.3.7.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.7.ebuild,v 1.10 2012/04/16 21:11:28 ranger Exp $
-
-EAPI=3
-
-# Can only add ruby19 support when ruby:1.9 is keyworded.
-#USE_RUBY="ruby18 ruby19"
-USE_RUBY="ruby18"
-RUBY_OPTIONAL="yes"
-
-PYTHON_DEPEND="python? *"
-
-EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
-[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
-inherit python multilib ruby-ng cmake-utils ${GIT_ECLASS}
-
-DESCRIPTION="Portable and multi-interface IRC client."
-HOMEPAGE="http://weechat.org/"
-[[ ${PV} == "9999" ]] || SRC_URI="http://${PN}.org/files/src/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-if [[ ${PV} == "9999" ]]; then
- KEYWORDS=""
-else
- KEYWORDS="amd64 ppc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-NETWORKS="+irc"
-PLUGINS="+alias +charset +fifo +logger +relay +rmodifier +scripts +spell +xfer"
-#INTERFACES="+ncurses gtk"
-SCRIPT_LANGS="guile lua +perl +python ruby tcl"
-IUSE="${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS} +crypt doc nls +ssl"
-
-RDEPEND="
- net-misc/curl[ssl]
- sys-libs/ncurses
- charset? ( virtual/libiconv )
- guile? ( dev-scheme/guile )
- lua? ( dev-lang/lua[deprecated] )
- perl? ( dev-lang/perl )
- ruby? ( $(ruby_implementations_depend) )
- ssl? ( net-libs/gnutls )
- spell? ( app-text/aspell )
- tcl? ( >=dev-lang/tcl-8.4.15 )
-"
-# ncurses? ( sys-libs/ncurses )
-# gtk? ( x11-libs/gtk+:2 )
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.15 )
-"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-#REQUIRED_USE=" || ( ncurses gtk )"
-
-LANGS=( cs de es fr hu it ja pl pt_BR ru )
-for X in "${LANGS[@]}" ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-pkg_setup() {
- use python && python_pkg_setup
- use ruby && ruby-ng_pkg_setup
-}
-
-src_prepare() {
- local i
-
- # fix libdir placement
- sed -i \
- -e "s:lib/:$(get_libdir)/:g" \
- -e "s:lib\":$(get_libdir)\":g" \
- "${S}/CMakeLists.txt" || die "sed failed"
-
- # install only required translations
- for i in "${LANGS[@]}" ; do
- if ! use linguas_${i} ; then
- sed -i \
- -e "/${i}.po/d" \
- "${S}/po/CMakeLists.txt" || die
- fi
- done
-}
-
-# alias, rmodifier, xfer
-src_configure() {
- # $(cmake-utils_use_enable gtk)
- # $(cmake-utils_use_enable ncurses)
- local mycmakeargs=(
- "-DENABLE_NCURSES=ON"
- "-DENABLE_LARGEFILE=ON"
- "-DENABLE_DEMO=OFF"
- "-DENABLE_GTK=OFF"
- $(cmake-utils_use_enable nls)
- $(cmake-utils_use_enable crypt GCRYPT)
- $(cmake-utils_use_enable spell ASPELL)
- $(cmake-utils_use_enable charset)
- $(cmake-utils_use_enable fifo)
- $(cmake-utils_use_enable irc)
- $(cmake-utils_use_enable logger)
- $(cmake-utils_use_enable relay)
- $(cmake-utils_use_enable scripts)
- $(cmake-utils_use_enable perl)
- $(cmake-utils_use_enable python)
- $(cmake-utils_use_enable ruby)
- $(cmake-utils_use_enable lua)
- $(cmake-utils_use_enable tcl)
- $(cmake-utils_use_enable guile)
- $(cmake-utils_use_enable doc)
- )
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if use scripts && use python; then
- elog "You may use the following script from upstream to manage your scripts."
- elog "It helps with downloading and updating other scripts:"
- elog " http://www.weechat.org/scripts/source/stable/weeget.py/"
- fi
-}
diff --git a/net-irc/weechat/weechat-0.3.8.ebuild b/net-irc/weechat/weechat-0.3.8.ebuild
index 9adc8949a619..d5e40adafa15 100644
--- a/net-irc/weechat/weechat-0.3.8.ebuild
+++ b/net-irc/weechat/weechat-0.3.8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.8.ebuild,v 1.1 2012/06/07 15:22:49 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.8.ebuild,v 1.2 2012/08/21 13:28:37 scarabeus Exp $
EAPI=4
-PYTHON_DEPEND="python? *"
+PYTHON_DEPEND="python? 2" # it can use only ONE python, so stick with two for now
EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
@@ -19,7 +19,7 @@ SLOT="0"
if [[ ${PV} == "9999" ]]; then
KEYWORDS=""
else
- KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-linux ~amd64-linux"
+ KEYWORDS="amd64 ppc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
fi
NETWORKS="+irc"
@@ -56,7 +56,10 @@ for X in "${LANGS[@]}" ; do
done
pkg_setup() {
- use python && python_pkg_setup
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index ccaa6f51c9f2..ceca01ebb28a 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.19 2012/05/31 11:15:05 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.20 2012/08/21 13:28:37 scarabeus Exp $
EAPI=4
-PYTHON_DEPEND="python? *"
+PYTHON_DEPEND="python? 2" # it can use only ONE python, so stick with two for now
EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
@@ -56,7 +56,10 @@ for X in "${LANGS[@]}" ; do
done
pkg_setup() {
- use python && python_pkg_setup
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {