summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2007-08-28 17:01:58 +0000
committerGeorge Shapovalov <george@gentoo.org>2007-08-28 17:01:58 +0000
commit8516dc1b0e6a9ce21050cc8c51db670f0f1c96c4 (patch)
tree889cbcb1710b993882e1befeb0cf6a17c09008e3 /net-dns/host
parentStable for HPPA (bug #185823). (diff)
downloadgentoo-2-8516dc1b0e6a9ce21050cc8c51db670f0f1c96c4.tar.gz
gentoo-2-8516dc1b0e6a9ce21050cc8c51db670f0f1c96c4.tar.bz2
gentoo-2-8516dc1b0e6a9ce21050cc8c51db670f0f1c96c4.zip
A long awaited update. Big thanks to Thomas S. Howard for fixing linking issue (#67973)
(Portage version: 2.1.3.6)
Diffstat (limited to 'net-dns/host')
-rw-r--r--net-dns/host/ChangeLog10
-rw-r--r--net-dns/host/files/digest-host-200701283
-rw-r--r--net-dns/host/host-20070128.ebuild54
3 files changed, 65 insertions, 2 deletions
diff --git a/net-dns/host/ChangeLog b/net-dns/host/ChangeLog
index 037835d6fb13..82095d487fad 100644
--- a/net-dns/host/ChangeLog
+++ b/net-dns/host/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/host
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/host/ChangeLog,v 1.3 2006/06/11 15:33:29 george Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/host/ChangeLog,v 1.4 2007/08/28 17:01:58 george Exp $
+
+*host-20070128 (28 Aug 2007)
+
+ 28 Aug 2007; George Shapovalov <george@gentoo.org> +host-20070128.ebuild:
+ A long awaited update. Big thanks to Thomas S. Howard for fixing linking
+ issue (#67973)
11 Jun 2006; George Shapovalov <george@gentoo.org> host-991529.ebuild:
changed RESTRICT=maketest to test
diff --git a/net-dns/host/files/digest-host-20070128 b/net-dns/host/files/digest-host-20070128
new file mode 100644
index 000000000000..9405b696437f
--- /dev/null
+++ b/net-dns/host/files/digest-host-20070128
@@ -0,0 +1,3 @@
+MD5 35156dce6b0905d741e67f53d24ea15b host-20070128.tar.gz 152347
+RMD160 955635175ee12882d59a10756d16af44ec62f9e7 host-20070128.tar.gz 152347
+SHA256 a2a56ab236f9e8549366175a3055e0dc7758dafd46658ed8bea58d87de39bd9f host-20070128.tar.gz 152347
diff --git a/net-dns/host/host-20070128.ebuild b/net-dns/host/host-20070128.ebuild
new file mode 100644
index 000000000000..9941deeb971d
--- /dev/null
+++ b/net-dns/host/host-20070128.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/host/host-20070128.ebuild,v 1.1 2007/08/28 17:01:58 george Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="A powerful command-line DNS query and test tool implementing many additional protocols"
+HOMEPAGE="http://www.weird.com/~woods/projects/host.html"
+SRC_URI="ftp://ftp.weird.com/pub/local/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RESTRICT="test"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if ! use debug; then
+ sed -i -e "/^CDEBUG/d" \
+ -e "/^DEBUGDEFS/d" \
+ Makefile || die "src_unpack failed"
+ fi
+
+ sed -i -e "/id-clash-30/d" \
+ -e "/^COPT/d" \
+ -e "s:^\(LDFLAGS = \)\(-static \)\(.*\):\1\3:" \
+ -e "s:^#\(RES_LIB = \)-lresolv:\1/usr/$(get_libdir)/libresolv.a:" \
+ -e "s:staff:root:" \
+ Makefile || die "src_unpack failed"
+
+ sed -i -e "s:^\(# if defined(__alpha).*\):\1 || defined(__x86_64__):" \
+ port.h || die "src_unpack failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" COPTS="${CFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ # This tool has slightly different format of output from "standard" host.
+ # Renaming it to host-woods, hopefully this does not conflict with anything.
+
+ newbin host host-woods || die "newbin failed"
+ newman host.1 host-woods.1 || die "newman failed"
+ dodoc RELEASE_NOTES ToDo || die "dodoc failed"
+}