summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/host/host-20070128.ebuild')
-rw-r--r--net-dns/host/host-20070128.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-dns/host/host-20070128.ebuild b/net-dns/host/host-20070128.ebuild
new file mode 100644
index 000000000000..9941deeb971d
--- /dev/null
+++ b/net-dns/host/host-20070128.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/host/host-20070128.ebuild,v 1.1 2007/08/28 17:01:58 george Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="A powerful command-line DNS query and test tool implementing many additional protocols"
+HOMEPAGE="http://www.weird.com/~woods/projects/host.html"
+SRC_URI="ftp://ftp.weird.com/pub/local/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RESTRICT="test"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if ! use debug; then
+ sed -i -e "/^CDEBUG/d" \
+ -e "/^DEBUGDEFS/d" \
+ Makefile || die "src_unpack failed"
+ fi
+
+ sed -i -e "/id-clash-30/d" \
+ -e "/^COPT/d" \
+ -e "s:^\(LDFLAGS = \)\(-static \)\(.*\):\1\3:" \
+ -e "s:^#\(RES_LIB = \)-lresolv:\1/usr/$(get_libdir)/libresolv.a:" \
+ -e "s:staff:root:" \
+ Makefile || die "src_unpack failed"
+
+ sed -i -e "s:^\(# if defined(__alpha).*\):\1 || defined(__x86_64__):" \
+ port.h || die "src_unpack failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" COPTS="${CFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ # This tool has slightly different format of output from "standard" host.
+ # Renaming it to host-woods, hopefully this does not conflict with anything.
+
+ newbin host host-woods || die "newbin failed"
+ newman host.1 host-woods.1 || die "newman failed"
+ dodoc RELEASE_NOTES ToDo || die "dodoc failed"
+}