summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-15 21:24:56 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-15 21:24:56 +0000
commit190300ece9347b4071b82bd0bec165356bdd39c9 (patch)
tree0e6c5fe086540005fb66dfaeb2bcc60f6c91143c /media-sound/mpg123
parent*** empty log message *** (diff)
downloadgentoo-2-190300ece9347b4071b82bd0bec165356bdd39c9.tar.gz
gentoo-2-190300ece9347b4071b82bd0bec165356bdd39c9.tar.bz2
gentoo-2-190300ece9347b4071b82bd0bec165356bdd39c9.zip
*** empty log message ***
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/files/digest1
-rw-r--r--media-sound/mpg123/mpg123-0.59r.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/mpg123/files/digest b/media-sound/mpg123/files/digest
new file mode 100644
index 000000000000..86378835775d
--- /dev/null
+++ b/media-sound/mpg123/files/digest
@@ -0,0 +1 @@
+MD5 95df59ad1651dd2346d49fafc83747e7 mpg123-0.59r.tar.gz
diff --git a/media-sound/mpg123/mpg123-0.59r.ebuild b/media-sound/mpg123/mpg123-0.59r.ebuild
new file mode 100644
index 000000000000..28ef2d459a45
--- /dev/null
+++ b/media-sound/mpg123/mpg123-0.59r.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.59r.ebuild,v 1.1 2000/08/15 21:24:56 achim Exp $
+
+P=mpg123-0.59r
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="media-sound"
+DESCRIPTION="Real Time mp3 player"
+SRC_URI="http://www.mpg123.de/mpg123/${A}"
+HOMEPAGE="http://www.mpg123.de/"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O2 -m486:${CFLAGS}:" Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ cd ${S}
+ make linux-i486
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin mpg123
+ doman mpg123.1
+ dodoc BENCHMARKING BUGS CHANGES COPYING JUKEBOX README* TODO
+
+
+}
+
+