summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-02-07 12:06:16 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-02-07 12:06:16 +0000
commita6a34086171f41d5d37ab2f57ffc7c566786fd55 (patch)
tree3e0c379502b2d8516b67576630183f4bd18cabb9 /games-fps
parentVersion bump (diff)
downloadgentoo-2-a6a34086171f41d5d37ab2f57ffc7c566786fd55.tar.gz
gentoo-2-a6a34086171f41d5d37ab2f57ffc7c566786fd55.tar.bz2
gentoo-2-a6a34086171f41d5d37ab2f57ffc7c566786fd55.zip
Fixed an error with sed and error check it in the ebuild and converted einfo to elog where appropriate.
(Portage version: 2.1.2-r6)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2004/ChangeLog8
-rw-r--r--games-fps/ut2004/ut2004-3369-r4.ebuild38
2 files changed, 25 insertions, 21 deletions
diff --git a/games-fps/ut2004/ChangeLog b/games-fps/ut2004/ChangeLog
index c54a7a6b2965..5d136ed3a7d2 100644
--- a/games-fps/ut2004/ChangeLog
+++ b/games-fps/ut2004/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/ut2004
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.59 2006/12/06 19:52:03 wolf31o2 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.60 2007/02/07 12:06:16 wolf31o2 Exp $
+
+ 07 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org> ut2004-3369-r4.ebuild:
+ Fixed an error with sed and error check it in the ebuild and converted einfo
+ to elog where appropriate.
06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> files/ut2004.xml,
ut2004-3369-r4.ebuild:
diff --git a/games-fps/ut2004/ut2004-3369-r4.ebuild b/games-fps/ut2004/ut2004-3369-r4.ebuild
index bcacae4cd6cb..9481b49bff8e 100644
--- a/games-fps/ut2004/ut2004-3369-r4.ebuild
+++ b/games-fps/ut2004/ut2004-3369-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ut2004-3369-r4.ebuild,v 1.14 2006/12/06 19:52:03 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ut2004-3369-r4.ebuild,v 1.15 2007/02/07 12:06:16 wolf31o2 Exp $
# To use system libraries, uncomment the following line and comment the one
# below it.
@@ -76,8 +76,8 @@ src_install() {
"${Ddir}"/System/ut2004-bin-linux-amd64
# Creating .manifest files
- sed -e "s/GAMES_PREFIX_OPT/${GAMES_PREFIX_OPT}/" "${FILESDIR}"/${PN}.xml > \
- ${T}/${PN}.xml
+ sed -e "s:GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" "${FILESDIR}"/${PN}.xml > \
+ ${T}/${PN}.xml || die "sed failed"
insinto "${dir}"/.manifest
doins "${T}"/${PN}.xml
@@ -105,25 +105,25 @@ pkg_postinst() {
ewarn "That way you can [re]enter your cdkey."
fi
echo
- einfo "Starting with 3369, the game supports render-to-texture. To enable"
- einfo "it, you will need the Nvidia drivers of at least version 7676 and"
- einfo "you should edit the following:"
- einfo 'Set "UseRenderTargets=True" in the "[OpenGLDrv.OpenGLRenderDevice]"'
- einfo 'section of your UT2004.ini/Default.ini and set "bPlayerShadows=True"'
- einfo 'and "bBlobShadow=False" in the "[UnrealGame.UnrealPawn]" section of'
- einfo 'your User.ini/DefUser.ini'
+ elog "Starting with 3369, the game supports render-to-texture. To enable"
+ elog "it, you will need the Nvidia drivers of at least version 7676 and"
+ elog "you should edit the following:"
+ elog 'Set "UseRenderTargets=True" in the "[OpenGLDrv.OpenGLRenderDevice]"'
+ elog 'section of your UT2004.ini/Default.ini and set "bPlayerShadows=True"'
+ elog 'and "bBlobShadow=False" in the "[UnrealGame.UnrealPawn]" section of'
+ elog 'your User.ini/DefUser.ini'
echo
if use x86
then
- einfo "The 32-bit version of UT2004 uses Pixomatic, which means it"
- einfo "really does need an executable stack. It is safe to ignore any"
- einfo "warnings from portage about this. See:"
- einfo "http://bugs.gentoo.org/show_bug.cgi?id=114733"
- einfo "for more information."
+ elog "The 32-bit version of UT2004 uses Pixomatic, which means it"
+ elog "really does need an executable stack. It is safe to ignore any"
+ elog "warnings from portage about this. See:"
+ elog "http://bugs.gentoo.org/show_bug.cgi?id=114733"
+ elog "for more information."
+ echo
fi
- echo
- einfo "To play the game run:"
- einfo " ut2004"
+ elog "To play the game run:"
+ elog " ut2004"
echo
}