summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-08-03 04:25:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-08-03 04:25:58 +0000
commit134bda09b1d7eb0cafa8f918837eefd400d90e73 (patch)
treef80fe548f2e6286b4b5eb65a1cf8e1b7357b3630 /games-action
parentversion bump (diff)
downloadgentoo-2-134bda09b1d7eb0cafa8f918837eefd400d90e73.tar.gz
gentoo-2-134bda09b1d7eb0cafa8f918837eefd400d90e73.tar.bz2
gentoo-2-134bda09b1d7eb0cafa8f918837eefd400d90e73.zip
patch from Daniel Santos to fix segfault (bug #422915)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/powermanga/ChangeLog8
-rw-r--r--games-action/powermanga/files/powermanga-0.90-segfault.patch22
-rw-r--r--games-action/powermanga/powermanga-0.90.ebuild8
3 files changed, 33 insertions, 5 deletions
diff --git a/games-action/powermanga/ChangeLog b/games-action/powermanga/ChangeLog
index 9c1255010d22..87fc5dc18466 100644
--- a/games-action/powermanga/ChangeLog
+++ b/games-action/powermanga/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/powermanga
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.21 2011/06/06 21:06:24 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.22 2012/08/03 04:25:58 mr_bones_ Exp $
+
+ 03 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/powermanga-0.90-segfault.patch, powermanga-0.90.ebuild:
+ patch from Daniel Santos to fix segfault (bug #422915)
06 Jun 2011; Michael Sterrett <mr_bones_@gentoo.org> powermanga-0.90.ebuild:
update libsdl dep to match the README
diff --git a/games-action/powermanga/files/powermanga-0.90-segfault.patch b/games-action/powermanga/files/powermanga-0.90-segfault.patch
new file mode 100644
index 000000000000..573a5794e399
--- /dev/null
+++ b/games-action/powermanga/files/powermanga-0.90-segfault.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/show_bug.cgi?id=422915
+
+--- tmp/powermanga-0.90.orig/src/shots.c 2007-08-24 00:55:17.000000000 -0700
++++ powermanga-0.90-dfsg/src/shots.c 2011-12-26 21:10:28.000000000 -0800
+@@ -447,8 +447,6 @@
+ {
+ bullet->img_angle = (Sint16) (bullet->angle / PI_SUR_16);
+ }
+- /* save current angle for the calculation of the next angle */
+- bullet->img_old_angle = bullet->img_angle;
+ /* avoid negative indexes */
+ bullet->img_angle = (Sint16) abs (bullet->img_angle);
+ /* avoid a shot angle higher than the number of images */
+@@ -456,6 +454,8 @@
+ {
+ bullet->img_angle = (Sint16) (bullet->spr.numof_images - 1);
+ }
++ /* save current angle for the calculation of the next angle */
++ bullet->img_old_angle = bullet->img_angle;
+ /* draw the shot sprite */
+ draw_sprite (bullet->spr.
+ img[bullet->img_angle],
diff --git a/games-action/powermanga/powermanga-0.90.ebuild b/games-action/powermanga/powermanga-0.90.ebuild
index 69187d38a62f..0f40e24c50b8 100644
--- a/games-action/powermanga/powermanga-0.90.ebuild
+++ b/games-action/powermanga/powermanga-0.90.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.90.ebuild,v 1.10 2011/06/06 21:06:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.90.ebuild,v 1.11 2012/08/03 04:25:58 mr_bones_ Exp $
EAPI=2
inherit eutils autotools games
@@ -32,7 +32,9 @@ src_prepare() {
#endif
EOF
done
- epatch "${FILESDIR}"/${P}-underlink.patch
+ epatch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-segfault.patch
eautoreconf
}