summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2005-09-23 14:24:10 +0000
committerFerris McCormick <fmccor@gentoo.org>2005-09-23 14:24:10 +0000
commit73bf04542a7df1f03aa2dec475b87a7df5ca5cae (patch)
tree972bfb22cf8c1af9168f2374f42ab3cb9ddb13f0 /dev-ruby/fxruby/fxruby-1.2.6.ebuild
parentAdded Slovak longdescription. (diff)
downloadgentoo-2-73bf04542a7df1f03aa2dec475b87a7df5ca5cae.tar.gz
gentoo-2-73bf04542a7df1f03aa2dec475b87a7df5ca5cae.tar.bz2
gentoo-2-73bf04542a7df1f03aa2dec475b87a7df5ca5cae.zip
Do not force '-O0' when building fxruby. Closes Bug #87016 at request
of the developer, caleb@gentoo.org. (Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-ruby/fxruby/fxruby-1.2.6.ebuild')
-rw-r--r--dev-ruby/fxruby/fxruby-1.2.6.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/fxruby/fxruby-1.2.6.ebuild b/dev-ruby/fxruby/fxruby-1.2.6.ebuild
index d4d91215e646..68462af7137f 100644
--- a/dev-ruby/fxruby/fxruby-1.2.6.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.2.6.ebuild,v 1.2 2005/09/23 02:05:59 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.2.6.ebuild,v 1.3 2005/09/23 14:24:10 fmccor Exp $
inherit ruby
@@ -27,4 +27,7 @@ src_unpack() {
sed -i -e 's:libs, "fxscintilla":libs, "fxscintilla-1.2":g' \
ext/fox12/extconf.rb || die "sed error"
+ einfo "Avoid -O0 builds"
+ sed -i -e 's:-O0 -Iinclude:-Iinclude:g' \
+ ext/fox12/extconf.rb || die "Can't fix forced -O0"
}