summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2005-09-23 14:24:10 +0000
committerFerris McCormick <fmccor@gentoo.org>2005-09-23 14:24:10 +0000
commit73bf04542a7df1f03aa2dec475b87a7df5ca5cae (patch)
tree972bfb22cf8c1af9168f2374f42ab3cb9ddb13f0 /dev-ruby/fxruby
parentAdded Slovak longdescription. (diff)
downloadgentoo-2-73bf04542a7df1f03aa2dec475b87a7df5ca5cae.tar.gz
gentoo-2-73bf04542a7df1f03aa2dec475b87a7df5ca5cae.tar.bz2
gentoo-2-73bf04542a7df1f03aa2dec475b87a7df5ca5cae.zip
Do not force '-O0' when building fxruby. Closes Bug #87016 at request
of the developer, caleb@gentoo.org. (Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-ruby/fxruby')
-rw-r--r--dev-ruby/fxruby/ChangeLog7
-rw-r--r--dev-ruby/fxruby/fxruby-1.2.2.ebuild10
-rw-r--r--dev-ruby/fxruby/fxruby-1.2.6.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/dev-ruby/fxruby/ChangeLog b/dev-ruby/fxruby/ChangeLog
index a3355f4cab8f..5abc43aca94f 100644
--- a/dev-ruby/fxruby/ChangeLog
+++ b/dev-ruby/fxruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fxruby
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.27 2005/09/23 02:07:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.28 2005/09/23 14:24:10 fmccor Exp $
+
+ 23 Sep 2005; Ferris McCormick <fmccor@gentoo.org> fxruby-1.2.2.ebuild,
+ fxruby-1.2.6.ebuild:
+ Do not force '-O0' when building fxruby. Closes Bug #87016 at request
+ of the developer, caleb@gentoo.org.
23 Sep 2005; Caleb Tennis <caleb@gentoo.org> -fxruby-1.0.28-r1.ebuild,
-fxruby-1.0.29.ebuild, -fxruby-1.2.4.ebuild, -fxruby-1.2.5.ebuild:
diff --git a/dev-ruby/fxruby/fxruby-1.2.2.ebuild b/dev-ruby/fxruby/fxruby-1.2.2.ebuild
index c56fa35cde8c..98b85cff418f 100644
--- a/dev-ruby/fxruby/fxruby-1.2.2.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.2.2.ebuild,v 1.8 2005/09/02 12:48:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.2.2.ebuild,v 1.9 2005/09/23 14:24:10 fmccor Exp $
inherit ruby
@@ -20,6 +20,14 @@ DEPEND=">=x11-libs/fox-1.2
USE_RUBY="ruby16 ruby18 ruby19"
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ einfo "Avoid all -O0 builds"
+ cd ${S}
+ sed -i -e 's:-O0 -Iinclude:-Iinclude:g' \
+ ext/fox12/extconf.rb || die "Can't fix forced -O0"
+}
+
src_compile() {
ruby install.rb config --prefix=/usr || die
ruby install.rb setup || die
diff --git a/dev-ruby/fxruby/fxruby-1.2.6.ebuild b/dev-ruby/fxruby/fxruby-1.2.6.ebuild
index d4d91215e646..68462af7137f 100644
--- a/dev-ruby/fxruby/fxruby-1.2.6.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.2.6.ebuild,v 1.2 2005/09/23 02:05:59 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.2.6.ebuild,v 1.3 2005/09/23 14:24:10 fmccor Exp $
inherit ruby
@@ -27,4 +27,7 @@ src_unpack() {
sed -i -e 's:libs, "fxscintilla":libs, "fxscintilla-1.2":g' \
ext/fox12/extconf.rb || die "sed error"
+ einfo "Avoid -O0 builds"
+ sed -i -e 's:-O0 -Iinclude:-Iinclude:g' \
+ ext/fox12/extconf.rb || die "Can't fix forced -O0"
}