summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-09-06 10:41:07 +0000
committerMichał Górny <mgorny@gentoo.org>2014-09-06 10:41:07 +0000
commit70b79f65b6c0b6961ef4503ca4e3fe99203724a9 (patch)
tree23df12d7428d882399c1c8bf5f0dc2b717981f9e /dev-python/pyxdg
parentWipe out references to removed Python targets. (diff)
downloadgentoo-2-70b79f65b6c0b6961ef4503ca4e3fe99203724a9.tar.gz
gentoo-2-70b79f65b6c0b6961ef4503ca4e3fe99203724a9.tar.bz2
gentoo-2-70b79f65b6c0b6961ef4503ca4e3fe99203724a9.zip
Enable python3.4 support, clean old targets.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/pyxdg')
-rw-r--r--dev-python/pyxdg/ChangeLog5
-rw-r--r--dev-python/pyxdg/pyxdg-0.25-r1.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/pyxdg/ChangeLog b/dev-python/pyxdg/ChangeLog
index 3a48f9c95f33..f1f7c0b194fc 100644
--- a/dev-python/pyxdg/ChangeLog
+++ b/dev-python/pyxdg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyxdg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/ChangeLog,v 1.120 2014/03/31 21:06:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/ChangeLog,v 1.121 2014/09/06 10:41:07 mgorny Exp $
+
+ 06 Sep 2014; Michał Górny <mgorny@gentoo.org> pyxdg-0.25-r1.ebuild:
+ Enable python3.4 support, clean old targets.
31 Mar 2014; Michał Górny <mgorny@gentoo.org> pyxdg-0.25-r1.ebuild,
pyxdg-0.25.ebuild:
diff --git a/dev-python/pyxdg/pyxdg-0.25-r1.ebuild b/dev-python/pyxdg/pyxdg-0.25-r1.ebuild
index 806caabf1226..97e579fad3a3 100644
--- a/dev-python/pyxdg/pyxdg-0.25-r1.ebuild
+++ b/dev-python/pyxdg/pyxdg-0.25-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/pyxdg-0.25-r1.ebuild,v 1.2 2014/03/31 21:06:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/pyxdg-0.25-r1.ebuild,v 1.3 2014/09/06 10:41:07 mgorny Exp $
EAPI=5
# py3.3 removed due to nosetests
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
inherit distutils-r1
DESCRIPTION="A Python module to deal with freedesktop.org specifications"
@@ -22,6 +22,7 @@ DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}]
DOCS=( AUTHORS ChangeLog README TODO )
PATCHES=( "${FILESDIR}"/sec-patch-CVE-2014-1624.patch )
+
python_test() {
nosetests || die
}