summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-22 07:15:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-22 07:15:08 +0000
commit919d7f37b829176eb1905bdc60cf501948866134 (patch)
treea833767e62673d46bcc69ab3222d682f027dcc10 /dev-python/pyconstruct/pyconstruct-2.5.0.ebuild
parentBump (diff)
downloadgentoo-2-919d7f37b829176eb1905bdc60cf501948866134.tar.gz
gentoo-2-919d7f37b829176eb1905bdc60cf501948866134.tar.bz2
gentoo-2-919d7f37b829176eb1905bdc60cf501948866134.zip
Bump
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pyconstruct/pyconstruct-2.5.0.ebuild')
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.5.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild b/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild
new file mode 100644
index 000000000000..b0b26186cba5
--- /dev/null
+++ b/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.5.0.ebuild,v 1.1 2013/01/22 07:15:08 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils
+
+MY_PN="construct"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="construct"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}